Mint 19.1 sur Dell D620/souci wifi [Résolu]

Messages postés
137
Date d'inscription
dimanche 21 janvier 2007
Statut
Membre
Dernière intervention
26 janvier 2019
-
Bonjour,

Un Dell Latitude D620 qui était sous Ubuntu 10 ou 12 ( mises à jour impossibles) mais qui me suffisait pour internet (wifi fonctionnait).

J'ai suivi conseils de passer à Mint 19.1 Cinnamon
  • Création clé usb bootable OK
  • Installation OK
  • Mises à jour via ethernet OK
  • Accès interrnet via ethernet OL
  • Souci avec wifi qui n'est as reconnu

Lors mise à jour des pilotes, cela m'a indiqué :

broadcom limited BCM4311 802.11b/g WLAN (wireless 1390 WLan mini card). Ce périphérique utilise un pilote alternatif
AU CHOIX
- bcmwl-kernel-source (version 6.30.223.271=bdcom-0ubuntu4, source du pilote réseau sans fil broadcom 802.11 linux STA
- ne pas utiliser le perihérique


=> j'ai fait le choix 1, donc message "un pilote propriétaire utilisé". Mais rien n'est détecté en wifi
J'ai regardé en connexion réseau, rien.
Dois je faire le choix 2 ?
J'ai essayé de renseigner ma box en direct, mais pas certaine de ce que j'ai renseigné... (SSID ?)

Je suis très très novice en Linux, donc si vous pouvez m'aider, merci de vos explications vocabulaire simple...
Merci par avance aux membres du forum
Poucina94

Les quelques demandes via le terminal que j'ai faites

-Latitude-D620:~$ lspci (extrait)
09:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Broadcom Limited BCM4311 802.11b/g WLAN (rev 01)

-Latitude-D620:~$ /sbin/iwconfig
enp9s0 no wireless extensions.
lo no wireless extensions.

-Latitude-D620:~$ /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 enp9s0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 enp9s0
192.168.1.0 0.0.0.0 255.255.255.0 U 100 0 0 enp9s0

-Latitude-D620:~$ cat /etc/resolv.conf
# This file is managed by man:systemd-resolved(8). Do not edit.
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
# Run "systemd-resolve --status" to see details about the uplink DNS servers
# currently in use.
# Third party programs must not access this file directly, but only through the
# symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a different way,
# replace this symlink by a static file or a different symlink.
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.
nameserver 127.0.0.53

-Latitude-D620:~$ nslookup www.google.fr
Server: 127.0.0.53
Address: 127.0.0.53#53
Non-authoritative answer:
Name: www.google.fr
Address: 216.58.206.227
Name: www.google.fr
Address: 2a00:1450:4007:811::2003

-Latitude-D620:~$ ping -c2 www.google.fr
PING www.google.fr (216.58.206.227) 56(84) bytes of data.
64 bytes from par10s34-in-f3.1e100.net (216.58.206.227): icmp_seq=1 ttl=54 time=48.0 ms
64 bytes from par10s34-in-f3.1e100.net (216.58.206.227): icmp_seq=2 ttl=54 time=47.7 ms
--- www.google.fr ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 47.766/47.890/48.014/0.124 ms

-Latitude-D620:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

-Latitude-D620:~$ cat /etc/wpa_supplicant/wpa_supplicant.conf
cat: /etc/wpa_supplicant/wpa_supplicant.conf: No such file or directory


Configuration: Linux / Firefox 64.0
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
137
Date d'inscription
dimanche 21 janvier 2007
Statut
Membre
Dernière intervention
26 janvier 2019
2
2
Merci
J'ai trouvé la solution en parcourant des forums

J'avais fait une mise à jour générale, mise à jour pilotes (donc installation automatique de
bcmwl
kernel source) par mon câble ethernet.

Ensuite effectivement, il fallait bien installer firmware b43

sudo apt-get install firmware-b43-installer


... mais mon wifi ne voulait toujours pas fonctionner.

Il a alors fallu que je supprime le pilote bcmwl-kernel-source redémarrer :

sudo apt-get remove bcmwl-kernel-source
sudo reboot


Et voilà, ma connexion wifi fonctionne !!! Mon réseau apparaît, mot de passe de la box rentré, et hop !

Merci à mamiemando pour l'aide apportée.

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 63075 internautes nous ont dit merci ce mois-ci

mamiemando
Messages postés
29016
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 octobre 2019
6664 -
Merci pour les compléments (et les compliments :p).

Juste quelques remarques depuis notre dernier échange :

1) Peut-être que mon ordinateur ne peut pas supporter mint 19 mais qu'il faudrait version antérieure ?

Il est peu probable qu'un linux soit "trop récent" pour être compatible avec du matériel. Linux essaye (contrairement à windows) de continuer à supporter les ordinosaures. Surtout qu'ici il était question d'un pilote wifi officiellement supporté.

Donc il ne faut pas se décourager dans ce genre de situation et ta persévérance a fini par payer ;-)

2) Comment vérifier que b43 est là ? + il a alors fallu que je supprime le pilote
bcmwl-kernel-source


Comme tu as pu l'observer, il faut effectivement, lorsqu'on installe un pilote (qui se présente généralement sous forme de module, au sens du noyau linux), s'assurer qu'il est effectivement chargé. Cela se vérifie avec la commande
lsmod
.

Au démarrage, le noyau linux charge automatiquement les modules qu'il estime nécessaire (*). Cela signifie que si deux modules semblent supporter un matériel donné, le noyau va charger l'un des deux modules candidats. Dans ton cas, pas de change, c'était le mauvais module, et c'est pour ça que tu as dû désinstaller
bcmwl-kernel-sources
.

(*) à noter que cette phase est influencée par différents fichiers de configuration, notamment les éventuelles blacklists configurées dans
/etc/modprobe.d
et des liste de modules à charger explicitement au démarrage (voir
/etc/modules
et
/etc/modules-load.d/modules.conf
).

Bonne continuation !
Commenter la réponse de poucina94
Messages postés
29016
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 octobre 2019
6664
1
Merci
Bonjour,

Actuellement, ta carte wifi n'est reconnue, comme le montre
iwconfig
. Il est donc inutile de tenter de la configurer à ce stade.

Pour commencer, essaye de redémarrer. Si un nouveau noyau a été installé, on sera sûr que tu es sûr le dernier, et si un firmware a été installé, on sera sûr qu'il est chargé.

Si le problème persiste, il faut reprendre l'installation du pilote. D'après la documentation ubuntu, il faut installer le paquet
firmware-b43-installer
via ta logithèque.

Bonne chance
Commenter la réponse de mamiemando
Messages postés
29016
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 octobre 2019
6664
1
Merci
il faut desinstaller kernell

Oulalala je ne sais pas où tu as vu ça mais certainement pas !! Il faut toujours que tu aies au moins un kernel (noyau linux) installé. Et il faut bien sûr ne pas désinstaller le kernel sur lequel tu as démarré (tu peux voir duquel il s'agit avec la commande
uname -a
).

Simplement, lorsque tu installes un pilote, celui-ci ne s'installe que pour les noyaux actuellement déployés.

En effet, contrairement aux autres paquets, pour les noyaux, on ne remplace pas l'existant : le nouveau noyau s'installe simplement à côté des autres (comme tu peux le voir par exemple dans
/lib/modules
et dans
/boot
).

Ça veut dire en particulier que si tu as installé un pilote autrement que via ta logithèque, le pilote ne sera pas installé pour le nouveau noyau.

Pour éviter ce genre de problème, on installe autant que possible un pilote via le gestionnaire de paquets (typiquement un paquet
firmware-...
,
driver-...
ou
...-dkms
sous debian). Ces paquets sont prévus pour être déployés lorsqu'un paquet lié à un noyau est installé (paquets
linux-image-...
)

Comme Ubuntu dérive de Debian, la logique est la même. Il y a juste certains paquets n'obéissent pas exactement à cette nomenclature (dont, visiblement,
b43-installer
). Il faut s'assurer que le pilote dont tu as besoin a bien été installé. Un bon moyen de s'en assurer est simplement de réinstaller le paquet
b43-installer
.

Bonne chance
Commenter la réponse de mamiemando
Messages postés
137
Date d'inscription
dimanche 21 janvier 2007
Statut
Membre
Dernière intervention
26 janvier 2019
2
0
Merci
Merci, oui j'ai vu cela, vite fait, mais je vais m'y remettre bien sérieusement, car le premier essai n'a pas fonctionné (il faut desinstaller kernell, et installer fichier b43 mais prendre le fichier du 32 bits en i386....) bref.... à refaire. je me suis retrouvée avec erreur initramfs busybox de laquelle j'ai eu bcp de mal à me dépetrer ! Heureusement, sur les forums on trouve des mésaventures identiques avec des solutions...
Suite ce week end je pense
Bonne soirée
Commenter la réponse de poucina94
Messages postés
137
Date d'inscription
dimanche 21 janvier 2007
Statut
Membre
Dernière intervention
26 janvier 2019
2
0
Merci
J'ai installé
b43-installer
, éteint, rallumé, mais j'ai toujours les mêmes resultats . Sauf si j'ai mal fait ?

Comment vérifier que b43 est là ?
(Quand je disais désinstaller le kernel, je voulais dire désinstaller la mise à jour du pilote kernel source proposée), mais en fait je l'ai remise avant de mettre b43.

Peut-être que mon ordinateur ne peut pas supporter mint 19 mais qu'il faudrait version antérieure ?

-Latitude-D620:~$ lspci (extrait)
09:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Broadcom Limited BCM4311 802.11b/g WLAN (rev 01)

-Latitude-D620:~$ /sbin/iwconfig
enp9s0 no wireless extensions.
lo no wireless extensions.


J'ai vérifié :

uname -a
Latitude-D620 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:44:00 UTC 2018 i686 i686 i686 GNU/Linux
Commenter la réponse de poucina94
Messages postés
137
Date d'inscription
dimanche 21 janvier 2007
Statut
Membre
Dernière intervention
26 janvier 2019
2
0
Merci
J'ai été cherché mes informations système :

System:    Host: -Latitude-D620 Kernel: 4.15.0-43-generic i686 bits: 32 compiler: gcc 
v: 7.3.0 Desktop: Cinnamon 4.0.9 wm: muffin dm: LightDM Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic
Machine: Type: Portable System: Dell product: Latitude D620 v: N/A serial: <filter> Chassis:
type: 8 serial: <filter>
Mobo: Dell model: 0FT292 serial: <filter> BIOS: Dell v: A08 date: 04/03/2007
Battery: ID-1: BAT0 charge: 86.6 Wh condition: 28.8/86.6 Wh (33%) volts: 12.1/11.1
model: Sanyo DELL KP4220 serial: <filter> status: Full
CPU: Topology: Dual Core model: Intel Core2 T5500 bits: 64 type: MCP arch: Core Merom rev: 6
L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6649
Speed: 997 MHz min/max: 1000/1667 MHz Core speeds (MHz): 1: 997 2: 997
Graphics: Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics vendor: Dell
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:27a2
Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa
resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 v: 1.4 Mesa 18.0.5
direct render: Yes
Audio: Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8
Sound Server: ALSA v: k4.15.0-43-generic
Network: Device-1: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCI Express
vendor: Dell Latitude D620 driver: tg3 v: 3.137 port: 10c0 bus ID: 09:00.0
chip ID: 14e4:1600
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Broadcom Limited BCM4311 802.11b/g WLAN vendor: Dell Wireless 1390
driver: N/A port: 10c0 bus ID: 0c:00.0 chip ID: 14e4:4311
Device-3: Dell Wireless 5505 Mobile Broadband (3G HSDPA) Minicard Modem type: USB
driver: option,option1 bus ID: 2-2.2:3 chip ID: 413c:8116
Drives: Local Storage: total: 74.53 GiB used: 6.71 GiB (9.0%)
ID-1: /dev/sda vendor: Hitachi model: HTS721080G9SA00 size: 74.53 GiB speed: <unknown>
serial: <filter>
Partition: ID-1: / size: 70.19 GiB used: 6.57 GiB (9.4%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 703.5 MiB used: 139.5 MiB (19.8%) fs: ext4 dev: /dev/sda1
ID-3: swap-1 size: 1.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2
Sensors: System Temperatures: cpu: 67.0 C mobo: N/A sodimm: 61.0 C
Fan Speeds (RPM): cpu: 3017
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main
2: deb http: //archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
3: deb http: //archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http: //archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Info: Processes: 186 Uptime: 33m Memory: 1.96 GiB used: 992.5 MiB (49.6%) Init: systemd
v: 237 runlevel: 5 Compilers: gcc: 7.3.0 alt: 7 Client: Unknown python3.6 client
inxi: 3.0.27
Commenter la réponse de poucina94