Menu

Complement de formule

Messages postés
9
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
11 février 2019
- - Dernière réponse : teoshrek
Messages postés
9
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
11 février 2019
- 11 févr. 2019 à 10:17
avec une petite combine:

feuil1 en AH2:
='2'!C2

et la formule, pour compter les 5:
=SOMMEPROD((SI(C2:AG2=AH2;C2:AG2=D2:AH2))*1)

attention, cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule
crdlmnt




Bonjour et meilleurs vœux à vous,

je reviens vers vous car votre formule fonctionne et je vous en remercie, mais si la cellule C2 de la feuille 2 n'est pas (RP) la formule inscrit "0" au lieu de 4 "RP" doubles. Quelle serait la formule pour lui faire compter les "RP double de la feuille "1 & 2" même si la première cellule de la feuille "2" n'est pas un RP

Merci

le lien pour voir le fichier est :

https://www.cjoint.com/c/IAijY4Ef04A
Afficher la suite 

Votre réponse

1 réponse

Messages postés
7632
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
22 février 2019
1641
0
Merci
Bonjour,

Peut-être comme ça :
https://mon-partage.fr/f/sbTkb1an/
teoshrek
Messages postés
9
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
11 février 2019
-
bonjour,

merci mais la formule qui est dans le tableau fonctionne bien si le premier jour du mois d'après est un RP mais ce n'est pas un RP elle ne fonctionne pas.
je ne trouve pas la solution
Patrice33740
Messages postés
7632
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
22 février 2019
1641 -
Tu n'a pas présenté le contexte, tu n'as pas dit qu'il s'agit de tableaux mensuels, c'est donc normal :
1) le premier jour du mois suivant n'est pas dans le tableau !
2) c'est logique puisqu'il n'est pas encore arrivé !
3) la logique voudrais que tu comptes le premier jour du mois d'avant !
4) mais actuellement il n'est pas reporté dans le tableau du mois concerné
teoshrek
Messages postés
9
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
11 février 2019
-
Bonjour,

dans le tableau il y a 2 feuilles Excel, dont un tableau sur la feuille 2 le premier jour est en RP, donc dans la formule de la feuille 1 on trouve bien 5 RP, mais si dans la feuille 2 le premier jour n'est pas un RP, dans la feuille 1 la formule compte 0 au lieu de 4. Pouvez vous me dire comment la modifier.
Merci
Commenter la réponse de Patrice33740