Menu

Dongle usb dwa 171

-
Bonjour,

mon pc portable ayant un problème de wifi, j'ai acheté le dongle D-link indiqué dans le titre me doutant que ce serait galère, et me voilà bloqué.

Je suis sous Debian 9.5.

J'ai installé plusieurs version des drivers :

rtl8812au et rtl8812AU_8821AU_linux a partir de git ou en téléchargement comme j'ai trouvé sur plusieurs tuto. Après quelques pérégrinations avec des dépendances qui manquaient il semblerait que ce soit ok.

Seul le premier a accepté la commande modprobe.

J'ai redémarré la machine.

mon dongle n'est visiblement pas détecté (la connexion wlp3s0 est celle de la carte réseau wifi interne) :

~$ /sbin/iwconfig
wlp3s0 IEEE 802.11 ESSID:"SFR_D898"
Mode:Managed Frequency:2.437 GHz Access Point: E0:A1:D7:3A:D8:9C
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off
Link Quality=46/70 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:141 Missed beacon:0

enp4s0 no wireless extensions.

lo no wireless extensions.


/sbin/ifconfig
enp4s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 54:e1:ad:9b:3b:70 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 65 base 0x9000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1 (Boucle locale)
RX packets 1404 bytes 106504 (104.0 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1404 bytes 106504 (104.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.96 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::7248:1229:a402:1e21 prefixlen 64 scopeid 0x20<link>
ether 60:14:b3:b4:3e:8d txqueuelen 1000 (Ethernet)
RX packets 4893 bytes 4954528 (4.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 4350 bytes 645206 (630.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


Je ne sais pas ce que je dois faire :

1) pour voir si mon drivers est correctement installé
2) pour configurer mon dongle

Configuration: Linux / Firefox 60.0
Afficher la suite 

Votre réponse

1 réponse

Messages postés
28814
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
10 mai 2019
8027
0
Merci
Bonjour,

Tu peux te référer à ce tutoriel. Dans ton cas, je pense que le pilote associé à ton dongle n'est pas installé ou mal installé. Sous debian il n'y a rien à
modprobe
a priori, il suffit d'installer le bon firmware et redémarrer.

Par ailleurs, on peut aussi oublier le dongle et regarder ce qui ne va pas avec ta carte interne. En particulier, celle-ci semble détectée, donc pourquoi ne pas simplement essayer de configurer le wifi avec elle ?

Quelle que soit la carte que tu décides d'essayer de faire fonctionner, reporte-nous les informations demandées dans la dernière section du tutoriel.

Bonne chance
Commenter la réponse de mamiemando