Menu

Moyenne excluant des valeurs [Résolu]

Messages postés
335
Date d'inscription
jeudi 12 février 2009
Statut
Membre
Dernière intervention
25 avril 2019
- - Dernière réponse : PC74cook32
Messages postés
335
Date d'inscription
jeudi 12 février 2009
Statut
Membre
Dernière intervention
25 avril 2019
- 17 janv. 2019 à 18:01
Bonjour,

J'ai un tableau excel qui doit calculer une moyenne.
Les valeurs prises en compte dans le calcul de la moyenne se situent en cases : B8;B11;B14;B17;B20;B23;B26; et B29.
Les valeurs de ces notes sont, soit un nombre (affiché par une formule), soit une case vide, soit le texte "Note manquante" indiqué par une formule.

Je souhaiterais que Excel me calcule la moyenne, SI il n'y a pas de cellules contenant le texte "Note manquante", tout en ne prenant pas compte des cellules vides.
J'ai essayé les sommes/nb si, les moyennes si ens et pourtant, je ne suis pas arrivé à mon but.

Par ex :
  • Si j'ai une case avec un nombre, 1 case avec "note manquante" et 6 vides ==> ne rien calculer ou afficher un texte d'erreur, peu importe.
  • Si j'ai une case avec un nombre, une autre avec un autre nombre et 6 vides ==> faire la moyenne des deux nombres.


J'espère avoir été assez clair, et vous remercie d'avance.
Afficher la suite 

Votre réponse

2 réponses

Messages postés
2383
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 mai 2019
254
0
Merci
Bonjour,

La formule moyenne() ne prend pas en compte les cellules vides et le cellules texte

=si(nb.si(plage;">0")>1; moyenne(plage);"")

Crdlmt
PC74cook32
Messages postés
335
Date d'inscription
jeudi 12 février 2009
Statut
Membre
Dernière intervention
25 avril 2019
35 -
Bonjour,

En faisant deux tests (cas 1 : une note, un "note manquante" et 6 vides; cas 2 : une note, 7 vides) ==> la formule m'affiche le #valeur

Visiblement cela viendrait du nb si, mais je n'ai pas pu trouver le problème

Merci d'avance
Commenter la réponse de DjiDji59430
Messages postés
2383
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 mai 2019
254
0
Merci
Tu ne peux pas mettre ton fichier sur https://www.cjoint.com/ ??
PC74cook32
Messages postés
335
Date d'inscription
jeudi 12 février 2009
Statut
Membre
Dernière intervention
25 avril 2019
35 -
Re,

Du coup pas besoin car problème résolu à l'instant :

J'ai imbriqué deux si, avec un ou qui me dit si au moins une cellule possède le texte "Note manquante". Dans ce cas, le deuxième si réagit et ne calcule pas la moyenne. Sinon, il calcule la moyenne.

Si ça peut intéresser, voici la formule :
=SI(SI(OU(I6="Note manquante";I9="Note manquante";I12="Note manquante";I15="Note manquante";I18="Note manquante";I21="Note manquante";I24="Note manquante";I27="Note manquante";);"nm";"pas nm")="nm";"Entrez les moyennes";MOYENNE(I6;I9;I12;I15;I18;I21;I24;I27))


Merci de ton aide.
Commenter la réponse de DjiDji59430