Menu

Formule avec plusieurs SI

Messages postés
54
Date d'inscription
mardi 22 août 2017
Dernière intervention
11 février 2019
- - Dernière réponse : PapyLuc51
Messages postés
1839
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
19 février 2019
- 11 févr. 2019 à 12:49
Bonjour,

j'essaye de faire une formule avec plusieurs SI imbriqué mais petit souci...

Fichier en pièce jointe, merci beaucoup.

https://www.cjoint.com/c/IAoqdT0PHS3
Afficher la suite 

Votre réponse

5 réponses

Messages postés
400
Date d'inscription
mardi 5 juin 2018
Dernière intervention
13 février 2019
29
0
Merci
Bonjour,

C'est la formule en J5 ? QU'est-ce que tu veux calculer ?

Cordialement.

Daniel
Commenter la réponse de danielc0
Messages postés
2267
Date d'inscription
samedi 19 avril 2008
Dernière intervention
21 février 2019
280
0
Merci
Bonjour,

si(I5>51<100) ==>si(et(i5>51;i5<100);

Crdlmt
Commenter la réponse de DjiDji59430
Messages postés
1839
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
19 février 2019
440
0
Merci
Bonsoir,

En transformant le tableau des émissions de CO2 pour utiliser une RECHERCHEV() et ainsi supprimer la série de SI()

https://www.cjoint.com/c/IAoq160Cywo


Cordialement
RAF26ML
Messages postés
54
Date d'inscription
mardi 22 août 2017
Dernière intervention
11 février 2019
-
super, merci beaucoup j'ai fait le deuxième tableau et ça marche, par contre comment faire pour qu'il recherche
si c'est du diesel ou de l'essence ?
PapyLuc51
Messages postés
1839
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
19 février 2019
440 -
J'ai pas fait gaffe, peut être que la formule rechercheV n'existait pas sur excel 97/2003 donc il faut bien aller sur une série de SI()

Pour éviter de mettre des ET() dans les conditions des si() j'ai commencé par le plus haut pour aller en dégrader

en J5 cette formule (à tirer vers le bas) j'ai fais référence aux cellules de la colonne B pour éviter de recopier les nombres qui peuvent changer.

=SI(I5="";"";I5*SI(I5>250;$B$24;SI(I5>200;$B$23;SI(I5>160;$B$22;SI(I5>140;$B$21;SI(I5>120;$B$20;SI(I5>100;$B$19;SI(I5>50;$B$18;0))))))))

Par contre le résultat est 0 si le nombre en I5 est <= à 50 ; c'est bien çà que tu veux ???

Le fichier initial avec cette formule

https://www.cjoint.com/c/IApnMWJOYAo

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
54
Date d'inscription
mardi 22 août 2017
Dernière intervention
11 février 2019
0
Merci
désolée pas pu répondre avant, en fait la colonne J avec la formule recherche V va très bien,
ce que je voulais, c'est faire une formule rechercher V pour le calcul de la colonne L,
une formule que ferait : si B5 = essence recherche V colonne essence sinon si b5 = diesel recherche colonne diesel.... pas facile à expliquer, j'ai commencé la formule dans le lien.

Merci

https://www.cjoint.com/c/IBljUKwv4Os
Commenter la réponse de RAF26ML
Messages postés
1839
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
19 février 2019
440
0
Merci
Bonjour

Les modifications sont sur le fichier en retour

Cordialement
Commenter la réponse de PapyLuc51