Menu

Cohérence entre deux colonne

- - Dernière réponse : diablo13800
Messages postés
1493
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 janvier 2019
- 14 janv. 2019 à 16:47
Bonjour à tous,

Je souhaiterai réaliser un contrôle sur deux colonnes Excel comme ci suit mais j'ai un soucis :

colonne A Colonne B
15654789 LL01-5634
15654789 LL01-5634
15654789 MP01-5464

si dans col A j'ai 15654789 et dans col B LL01-5634 alors je veux vérifier qu'à chaque fois que j'aurai 15654789 dans ma col A j'aurai LL01-5634 dans ma col B sinon je renvoie un message d'erreur. je souhaiterai généraliser cela avec plusieurs références différentes dans Col A

Merci beaucoup
Afficher la suite 

Votre réponse

3 réponses

Messages postés
23291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2019
5542
0
Merci
Bonjour
si j'ai bien compris:
si on commence en A2,
formule glissante, bien respecter la position des signes $ pour que le défaut s'affiche sur la bonne ligne:
en C2, à tirer sur la hauteur utile

=SI(NB.SI($A$2:A2;A2)=NB.SI.ENS($A$2:A2;A2;$B$2:B2;B2);"OK";"nonOK")

crdlmnt



Commenter la réponse de Vaucluse
Messages postés
1493
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 janvier 2019
449
0
Merci
Bonjour,

Formule à tester, en imaginant qu'en feuil2 vous avez toute votre liste de référence

=Si(RechercheV(A2;Feuil2!A:B;2;FAUX)=B2;"Cohérent";"Erreur")

Ca devrait fonctionner.
Commenter la réponse de diablo13800
0
Merci
Merci beaucoup pour votre rapidité Vaucluse et Diablo 13800 !!!! vos deux réponses me conviennent.
juste une petite question si je veux le coder sous VBA en enregistrant la formule pensez-vous que je pourrais en tirer le code ?
Merci
diablo13800
Messages postés
1493
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 janvier 2019
449 -
Sous VBA la fonction serait bien différente. Si vous utilisez l'enregistreur de macro il vous indiquera seulement comment rentrer la formule pas son véritable fonctionnement.
Très bien merci ! il s'agira dans ce cas de boucler mes deux instruction incluses correspondants aux fonctions NB.SI et NB.SI.ENS ?
diablo13800
Messages postés
1493
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 janvier 2019
449 -
Plus ou moins.

il vous faudra boucler sur les différentes colonnes pour pouvoir faire des recherches.
Commenter la réponse de bryard