Menu

Formule de comptage

- - Dernière réponse : Vaucluse
Messages postés
23316
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2019
- 14 janv. 2019 à 11:36
Bonjour et meilleurs vœux à vous,

feuil1 en AH2:
='2'!C2

et la formule, pour compter les 5:
=SOMMEPROD((SI(C2:AG2=AH2;C2:AG2=D2:AH2))*1)

attention, cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule
crdlmnt

MAIS

je reviens vers vous car votre formule fonctionne et je vous en remercie, mais si la cellule C2 de la feuille 2 n'est pas (RP) la formule inscrit "0" au lieu de 4 "RP" doubles. Quelle serait la formule pour lui faire compter les "RP double de la feuille "1 & 2" même si la première cellule de la feuille "2" n'est pas un RP.

le lien pour voir le fichier est :

https://www.cjoint.com/c/IAijY4Ef04A
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23316
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2019
5551
0
Merci
Bonjour
votre formule ne fonctionnera pas en ligne 13 puisque vous comptez kk (AH13) (qui vient de l'autre feuille) au lieu de RP
deux façons de régler ça:
soit vous remplacer le AH2 ou le AH13 par "RP" (entre guillemets)
soit vous entrez RP dans une cellule hors champ et vous remplacer dans les deux formules le AHxx par l'adresse de cette cellule
crdlmnt

Commenter la réponse de Vaucluse