Menu

Blocage sur une formule [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
23345
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
- 17 janv. 2019 à 07:18
bonjour,
j'ai un blocage sur une formule, je m'explique
j'ai 2 colonnes de 10 lignes, de A2 à A11 et de B2 à B11
au dessus une cellule en A1 jumelée avec la B1
dans la colonne de gauche, chaque cellule a une liste déroulante de plusieurs villes (bordeaux, dijon, lille, lyon,etc...., et sur une feuille à part appelée paramètres dans la cellule F1 il y est noté le nom d'une ville, soit ici Lille, comme ça tout est réglé et géré sur la ville. j'ai dédoublé le nombre de classeur en le nombre de ville.
dans la colonne de droite chaque cellule a 2 mots : mission et formation
je sais calculer le nombre de mission dans la ville de lille
=NB.SI.ENS(B2:B11;"MISSION";B2:B11;PARAMETRES!$F$1)
par contre je n'arrive pas à calculer le nombre de missions de toutes les villes hormis Lille
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
23345
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
5561
1
Merci
Bonjour
et pourquoi ne pas faire simplement:

=NB.SI(B2:B11;"Mission")-NB.SI.ENS(B2:B11;"MISSION";B2:B11;PARAMETRES!$F$1)

ou alors:

=SOMMEPROD((B2:B11="Mission")*(PARAMETRES!B2:B11<>$F$1)

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58463 internautes nous ont dit merci ce mois-ci

Merci pour vos réponses dès que je serai devant mon ordi je vous tiendrai au courant. A bientôt
Commenter la réponse de Vaucluse
Messages postés
1347
Date d'inscription
lundi 22 août 2016
Dernière intervention
23 janvier 2019
5
0
Merci
Bonjour,
Ok, est-ce que tu peux me donner stp les données que t'as mis de A2 à A11 et de B2 à B11.
Bonjour,
De A2 à A11 chaque cellule a une liste déroulante de 10 villes.
De B2 à B11 chaque cellule a une liste déroulante de mots "mission et formation"
Commenter la réponse de lolomusic667
Messages postés
1347
Date d'inscription
lundi 22 août 2016
Dernière intervention
23 janvier 2019
5
0
Merci
NB.SI permet de déterminer le nombre de cellules non vides répondant à la condition à l'intérieur de la plage.
Par contre sommeprod, je ne connais pas.

Quel type de formule correspondrait à ta demande ?
Vaucluse
Messages postés
23345
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
5561 -
et si on laissait le demandeur essayer? ça vous confirmerait peut être le fonctionnement de SOMMEPROD.
lolomusic667
Messages postés
1347
Date d'inscription
lundi 22 août 2016
Dernière intervention
23 janvier 2019
5 > Vaucluse
Messages postés
23345
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
-
d'accord. Le demandeur ne dit rien.
Commenter la réponse de lolomusic667
0
Merci
Merci pour vos réponses dès que je serai devant mon ordi je vous tiendrai au courant. A bientôt
Commenter la réponse de TSE62153
0
Merci
En tout cas merci à tous. Vous m'avez bien dépatouillés, génial ça marche. A bientôt
Commenter la réponse de TSE62153
Messages postés
23345
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
5561
0
Merci
Ok
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse