Menu

Combinaison de la fonction SI et OU

- - Dernière réponse : PHILOU10120
Messages postés
5196
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 janvier 2019
- 11 janv. 2019 à 12:22
Bonjour,
J'essaie tant bien que mal d'arriver à écrire la formule suivante, mais je n'y arrive pas.
Je voudrais inscrire ceci:

Si la date indiquée dans la cellule AJ est entre 2015-04-01 et 2016-03-01 alors écrire 2015-2016; sinon, si la date indiquée dans la AJ est entre le 2016-04-01 et 2017-03-31 alors écrire 2016-2017. Et je dois faire ça jusqu'en 2025.

Merci de m'aider


Configuration: Windows / Chrome 49.0.2623.112
Afficher la suite 

Votre réponse

2 réponses

Messages postés
24180
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
17 janvier 2019
9804
0
Merci
Bonjour,

Et si on testait juste le mois
=SI(MOIS(A1)>3;ANNEE(A1)&"-"&ANNEE(A1)+1;ANNEE(A1)-1&"-"&ANNEE(A1)) 

Je suppose que tu voulais écrire 2016-03-31 plutôt que 2016-03-01, et que ton champ (A1 dans mon exemple) est bien un format date, même s'il n'est pas affiché dans un format français ;-)

Commenter la réponse de jee pee
Messages postés
5196
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 janvier 2019
764
0
Merci
Bonjour ValPro

Une idée avec une table de référence et une fonction RECHERCHEV(…)

https://www.cjoint.com/c/IAllwqK1gvx
Commenter la réponse de PHILOU10120