Menu

Fonction si à partir d'une recherchev

- - Dernière réponse : Vaucluse
Messages postés
23319
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
- 8 janv. 2019 à 17:41
Bonjour,

Je viens vers vous car je ne trouve nulle part la solution à mon problème.

voici la situation :
J'ai une colonne avec des dates de naissances qui proviennent d'une autre feuille de mon classeur Excel grâce à une recherche V
cellule C25 ( date de naissance ) : =RECHERCHEV(B25;FTP;2;0)

Je souhaite mettre en place une fonction si dans une colonne "retraite" afin de savoir qui est susceptible de partir en retraite l'année x avec 1 si oui, sinon rien.
cellule M25 ( retraite ) : =SI(ET(C25>DATE(1961;1;1);C25<DATE(1961;12;31));1;"")

Cette fonction si ne fonctionne pas lorsque la date de naissance provient de ma Recherchev
Si je saisie moi même la date de naissance, cette formule fonctionne.

Avez vous une solution afin que ma fonction Si détecte une date et non une formule ?

en espérant que vous pourrez m'aider !

Merci d'avance :)
Afficher la suite 

Votre réponse

2 réponses

Messages postés
424
Date d'inscription
lundi 22 septembre 2008
Dernière intervention
19 janvier 2019
66
0
Merci
Bonjour,

Il y a des chances pour que les dates soient au format texte
Commenter la réponse de M-12
Messages postés
23319
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
5551
0
Merci
Bonjour

Probablement oui,M_12 a raison, une colonne qui n'est pas au format dates

essayez pour vérifier votre colonne de date en affichant en format nombre standard. Les dates doivent s'afficher en nombre à 5 chiffres
si ce n'est pas le cas, essayez:
  • de copier une cellule vide
  • de sélectionner le champ de dates
  • collage spécial / "addition"

pour tenter de renumériser les données
et si ça ne va toujours pas, il faudra nous dire à quoi ressemble vos dates;
à vous lire
crdlmnt
Commenter la réponse de Vaucluse