Menu

SI avec 3 critères

Messages postés
9
Date d'inscription
vendredi 17 août 2012
Dernière intervention
5 janvier 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
47964
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
- 5 janv. 2019 à 02:48
Bonsoir, et surtout une Bonne Année aux membres du forum

Je voudrai réaliser un produit a partir d'une plage de cellules en fonction de 3 critères.

En O5 une quantité
En R5 un prix m2
En S5 un prix m3
En T5 un prix Kg
En U5 résultat

Je n'arrive pas a trouver la formule qui prendrai la cellule de l'unité choisie , les 2 autres cellules étant vides.

Si un membre du forum peut m'aider, merci d'avance
Afficher la suite 

Votre réponse

2 réponses

Messages postés
24198
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
19 janvier 2019
9822
0
Merci
Bonjour,

Avec les cellules ABCDE
=SI(ESTVIDE(B2);(SI(ESTVIDE(C2);(SI(ESTVIDE(D2);0;A2*D2));A2*C2));A2*B2) 

ou aussi
=GRANDE.VALEUR(B2:D2;1)*A2


jpc1948
Messages postés
9
Date d'inscription
vendredi 17 août 2012
Dernière intervention
5 janvier 2019
-
Bonsoir et merci de la réponse, cependant ça ne fonctionne pas correctement.
Pour avoir un résultat il faut 2 cellules remplies,....? sinon j'ai 0...?
Commenter la réponse de jee pee
Messages postés
47964
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
15488
0
Merci
Bonjour jpc.

=O5*(R5+S5+T5)
devrait suffire
Commenter la réponse de Raymond PENTIER