Menu

EQUIV MIN sur plusieurs feuilles [Résolu]

Messages postés
10
Date d'inscription
mercredi 11 mars 2015
Dernière intervention
7 janvier 2019
- - Dernière réponse : j0ule
Messages postés
10
Date d'inscription
mercredi 11 mars 2015
Dernière intervention
7 janvier 2019
- 4 janv. 2019 à 10:02
Bonjour à tous,

J'ai un tableau identique à celui ci dans 5 feuilles différentes ( 1 par fournisseur ).


J'ai réussi à faire un tableau global qui m'affiche le prix minimum proposé parmi les 5 offres des fournisseurs avec une fonction basique : la fonction MIN.

Par contre malgré mes recherches , je n'arrive pas à obtenir le même tableau mais avec le nom du fournisseur le moins cher dans chaque case. Ce nom se trouve pour chaque feuille en A1.
J'ai cru comprendre qu'il faut utiliser les Fonctions EQUIV et INDEX mais sur plusieurs feuilles je n'aboutis à rien

Quelqu'un aurait-il une solution pour moi ? :)

Bonne journée à tous

Configuration: Windows / Chrome 71.0.3578.98
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23342
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
5561
0
Merci
Bonjour
on ne voit pas trop d'ns quels champs vous voulez trouver le minimum. S'agit iol de traiter chaque colonne sur les 5 feuilles?
si oui,
1° formule pour trouver le mini, par exemple dans une colonne de B2 à B100 pour feuil1 à Feuil5
dans une cellule Z1 pour l'exemple
=MIN(MIN(Feuil1!B1:B100);MIN(Feuil2!B1:B100);MINB(Feuil3!B1:B100);MIN(Feuil4!B1:B100);MIN(Feuil5!B1:B100))


et pour trouver dans quel fournisseur se trouve se mini:

en Z2:
SI(NB.SI(Feuil1!B1:B100;Z1);Feuil1!A1;SI(NB.SI(Feuil2!B1:B100)=Z1;Feuil2!A1;SI(NB.SI(Feuil3!B1:B100;Z1);Feuil3!A1;SI(NB.SI(Feuil4!B1:B100;Z1);Feuil4!B1:B100;Feuil5!B1:B100))))

mais ce ne sont que des suppositions à adapter
si problème, revenez avec plus d'info sur les valeurs à comparer

crdlmnt
j0ule
Messages postés
10
Date d'inscription
mercredi 11 mars 2015
Dernière intervention
7 janvier 2019
-
Bonjour,

Chaque cellule est à comparer une à une de b4 à L16. le mini de B4 entre les feuilles 1; 2; 3; 4 et 5 et ainsi de suite. Pour obtenir le montant le plus bas j'ai fait comme vous dites avec la formule min, jusque là pas de soucis.

Par contre si en B4 le min qui ressort est 580, j'aimerai savoir quel fournisseur a proposé ce tarif. Donc si cette valeur vient de la feuille 1; 2; 3; 4 ou 5. sachant que le nom de chaque fournisseur se trouve en A1 sur chaque feuille

Je ne sais pas si je suis très claire ? pas évident désolé
Vaucluse
Messages postés
23342
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
5561 -
je vous ai proposé ça en deux cellules, une pour le mini est un pour le nom du fournisseur
soit avec les précisions que vous donnez maintenant, donc ne comparer qu'"une seule cellule de chaque feuille:
cell 1=MINB(Feuil!B4;Feuil2!B4;Feuil3!B4;Feuil4!B4;Feuil5!B5)
et pour trouver le fournisseur:
=SI(Feuil1!B4=Cell1;Feuil1!$A$1;SI(Feuil2!B4=Cell1;Feuil2!$A$1;SI(Feuil3!B4=Cell1;Feuil3!$A$1;SI(Feuil4!B4=Cell1;Feuil4!$A$1;Feuil5!$A$1))))
cell1 étant l'adresse de la cellule qui calculeCell1 le mini.pour fair cela en une seule formule, il faut remplace à chaque fois par la 1° formule qui calcule le mini.?
=SI(Feuil1!B4=MIN(Feuil!B4;Feuil2!B4;Feuil3!B4;Feuil4!B4;Feuil5!B5);Feuil1!$A$1;..... etc........

La difficulté vient de la répartition sur 5 feuilles des résultats. Il aurait mieux valu créer une seule feuille avec à chaque fois 5 colonnes par rubrique pour placer les fournisseur. Il aurait alors été possible d'utiliser INDEX/EQUIV avec le code DECALER

crdlmnt
j0ule
Messages postés
10
Date d'inscription
mercredi 11 mars 2015
Dernière intervention
7 janvier 2019
-
Super tout fonctionne ! Merci beaucoup !
Commenter la réponse de Vaucluse