Recherche approximative [Résolu]

Messages postés
3
Date d'inscription
dimanche 30 décembre 2018
Statut
Membre
Dernière intervention
5 janvier 2019
- - Dernière réponse : Finaref
Messages postés
3
Date d'inscription
dimanche 30 décembre 2018
Statut
Membre
Dernière intervention
5 janvier 2019
- 5 janv. 2019 à 03:22
Bonjour le forum,

je m'arrache les cheveux sur une formule, alors je viens chercher de la rescousse.

J'effectue une recherche entre 2 listes. La particularité est que la clé n'est pas strictement identique.
Par exemple, sur une colonne :
PN_1
PN_2

sur 2 autres colonnes : PN - Peugeot.
Je souhaite afficher dans ma cellule Peugeot quand il y a PN_1 et PN_2.

Ben, je n'y arrive pas.Je suis passé par le RECHERCHEV avec la recherche approximative, mais ca part dans tous les sens. Copie d'écran ci-dessous avec la formule renseignée.
Help. :)



Merci pour vos réponses et très bonne fin d'année 2018. ^^

Configuration: Windows / Chrome 71.0.3578.98
Afficher la suite 

4 réponses

Messages postés
11235
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 octobre 2019
1466
0
Merci
Bonsoir Finaref

RECHERCHEV(GAUCHE(B2;2) & "*" ;E2:F6;2;0) devrait faire l'affaire

Cdlmnt
Via
Finaref
Messages postés
3
Date d'inscription
dimanche 30 décembre 2018
Statut
Membre
Dernière intervention
5 janvier 2019
-
Bonsoir via55,

Merci, ca me fait avancer d un grand pas ! Mais la marche n est pas encore totalement franchie.

Mon exemple était un chouilla plus simple que la réalité.
Je n ai pas toujours une combinaison sur 2 lettres, ça varie entre 2 et 3 (exemple : PN* et FOR*). Ça se finit toujours par une *.

Une dernière complexité est un cas particulier au sein duquel la clé ne se distingue que sur le 3eme caractère (exemple : FO* et FOR*).

Merci !
Commenter la réponse de via55
Messages postés
11235
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 octobre 2019
1466
0
Merci
Bonjour

La logique et l'efficacité voudraient que tous les codes comporte le même nombre de lettres, c'est la base !
Néanmoins essaie cette formule qui teste d'abord 3 lettres puis 2
=SIERREUR(INDEX(F:F;EQUIV(GAUCHE(B1;3);E:E;0));INDEX(F:F;EQUIV(GAUCHE(B1;2);E:E;0)))

Cdlmnt
Via
Commenter la réponse de via55
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842
0
Merci
Bonjour
(et salut Via, ça va en cette fin d'année?)

Voyez si ce modèle peut s'appliquer à votre problème. Surtout, v oyez si vous pouvez pour votre recherche, respecter les conditions stipulées dans les notes
et revenez si problème
https://mon-partage.fr/f/8CUD5Y4x/

crdlmnt
Vaucluse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842 -
suite du message: à noter que, après test, la présence ou non de l'astérisque à la fin des codes de référence ne paraît pas influencer les résultats si les conditions de textes sont respectées.
Commenter la réponse de Vaucluse
Messages postés
3
Date d'inscription
dimanche 30 décembre 2018
Statut
Membre
Dernière intervention
5 janvier 2019
0
Merci
Merci à vous pour vos réponses et votre aide. ^^

Bon we !
Commenter la réponse de Finaref