Menu

Excel : recherche de dates (par mois et année)

Messages postés
4
Date d'inscription
vendredi 28 décembre 2018
Dernière intervention
8 janvier 2019
- - Dernière réponse : michel_m
Messages postés
15610
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 janvier 2019
- 8 janv. 2019 à 16:45
Bonjour à tous,

j'ai un tableau avec des dates xx/xx/xxxx et en face de chaque un intitulé, un montant

ex :
prêt /// 24/01/2019 /// 200€
EDF /// 26/01/2019 /// 80€
Téléphone /// 15/01/2019 /// 29,99
prêt /// 24/02/2019 /// 200€
EDF /// 26/02/19 /// 80€
Téléphone /// 15/02/2019 /// 29,99


je cherche à rapatrier dans un autre tableau, par formule, tout ce qui, dans le 1er tableau, concerne janvier 2019, par exemple
puis un autre tableau pour février 2019 etc.

j'ai cherché sur le net et ici, mais je ne trouve rien qui correspond....


merci à vous pour votre aide
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
Messages postés
362
Date d'inscription
mardi 5 juin 2018
Dernière intervention
17 janvier 2019
28
1
Merci
Bonjour,

Si tu veux additionner ce qui est en janvier 2019, avec les dates en colonne E et les montants en colonne D :

=SOMME.SI.ENS(D:D;E:E;">=1/1/19";E:E;"<=31/1/19")

Daniel

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56028 internautes nous ont dit merci ce mois-ci

Commenter la réponse de danielc0
Messages postés
23309
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2019
5548
1
Merci
Bonjour
vous voulez rapatrier quoi?
les lignes du tableau, le cumul des montants, le nombre de lignes avec une date
précisez
à vous lire
crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56028 internautes nous ont dit merci ce mois-ci

Dazz49
Messages postés
4
Date d'inscription
vendredi 28 décembre 2018
Dernière intervention
8 janvier 2019
-
merci à vous pour vos réponses

alors j'ai donc un 1er onglet :

prêt /// 24/01/2019 /// 200€
EDF /// 26/01/2019 /// 80€
Téléphone /// 15/01/2019 /// 29,99
prêt /// 24/02/2019 /// 200€
EDF /// 26/02/19 /// 80€
Téléphone /// 15/02/2019 /// 29,99

et je voudrais faire des onglets par mois, par exemple onglet janvier 2019 avec formules allant chercher "toutes seules" les lignes dont la date "contient" janvier 2019
(au pire les onglets de chaque mois pourraient déjà faire figurer les intitulés "prêt", "EDF" etc mais j'aimerais plutôt que ça rapatrie TOUT ce qui concerne le mois directement)

J'espère avoir été plus clair sur ma demande


Cordialement,
danielc0
Messages postés
362
Date d'inscription
mardi 5 juin 2018
Dernière intervention
17 janvier 2019
28 > Dazz49
Messages postés
4
Date d'inscription
vendredi 28 décembre 2018
Dernière intervention
8 janvier 2019
-
Bonjour,

Les données initiales sont sur Feuil2 (à modifier). sur la feuille cible, j'ai mis la date "01/01/2018" en P1.
En A1 :
=SIERREUR(INDEX(Feuil2!A$1:A$6;AGREGAT(15;6;(1/(((MOIS(Feuil2!$B$1:$B$6))=MOIS($P$1)*(ANNEE(Feuil2!$B$1:$B$6)=ANNEE($P$1)))*((MOIS(Feuil2!$B$1:$B$6))=MOIS($P$1)*(ANNEE(Feuil2!$B$1:$B$6)=ANNEE($P$1))))*LIGNE($B$1:$B$6));LIGNE(A1)));"")

à recopier vers le bas et vers la droite.

Daniiel
Dazz49
Messages postés
4
Date d'inscription
vendredi 28 décembre 2018
Dernière intervention
8 janvier 2019
-
merci !
Commenter la réponse de Vaucluse
Messages postés
15610
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 janvier 2019
3576
1
Merci
Bonjour à tous,

cela se fait en 5 minutes sans manipuler de formules avec un tableau croisé dynamique ;o)

https://mon-partage.fr/f/lnngGVXo/

Oups!: sur le classeur, lire "grouper" au lieu de "dissocier" :-/

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56028 internautes nous ont dit merci ce mois-ci

danielc0
Messages postés
362
Date d'inscription
mardi 5 juin 2018
Dernière intervention
17 janvier 2019
28 -
Bonjour,

Ca ne prend même qu''une minute pour comprendre que le TCD agrège les données source. C'est à dire que si tu as deux prêts à la même date, tu n'auras pas le détail. Sauf à double-cliquer sur le montant.

;o)
Commenter la réponse de michel_m
Messages postés
22292
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 janvier 2019
7139
1
Merci
Bonjour,

voir même un simple filtre qui permet de filtrer par année/mois.
eric

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56028 internautes nous ont dit merci ce mois-ci

michel_m
Messages postés
15610
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 janvier 2019
3576 -
Bonjour Eric
effectivement! je n'y avais pas pensé: c'est encore Plus simple §
Commenter la réponse de eriiic
Messages postés
4
Date d'inscription
vendredi 28 décembre 2018
Dernière intervention
8 janvier 2019
0
Merci
Merci à vous ! Les TCD, j'avais pas pris le temps de m'y pencher, mais je vais m'y mettre
Commenter la réponse de Dazz49