Extraction texte [Résolu]

Messages postés
138
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
14 mars 2019
- - Dernière réponse : nihcoc
Messages postés
138
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
14 mars 2019
- 22 déc. 2018 à 17:18
Bonjour,
je cherche a extraire le texte a gauche du point d'interrogation,
exemple " la nuit est calme? "
résultat " la nuit est calme " .
J'ai trouvé cette formule qui marche avec d'autres signes,mais pas avec ?
=SI(ESTERREUR(CHERCHE("?";A1));A1;GAUCHE(A1;CHERCHE("?";A1)-1))

Pourquoi ? ,
et si quelqu'un avait une idée d'avance merci.




Configuration: Windows / Firefox 64.0
Afficher la suite 

3 réponses

Messages postés
25958
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
23 juillet 2019
5337
0
Merci
Bonjour

Qui cherche trouve ;-)
=SI(ESTERREUR(TROUVE("?";A1));A1;GAUCHE(A1;TROUVE("?";A1)-1)) 

Commenter la réponse de jee pee
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
3522
0
Merci
Bonjour,

avec certain symboles ou signe de ponctuation il faut faire précéder le signe d'un ~
par contre pour saisir ce ~ il faut cliquer deux fois sur Alt GR et la touche 2 ce qui va générer deux ~~ il suffit d'en supprimer un ou Alt Gr puis la touche 2 et clic sur la touche espace
=GAUCHE(A1;CHERCHE("~?";A1;1)-1)

tu peux ajouter une gestion d'erreur plus simple depuis Excel 2007 =SIERREUR(GAUCHE(A1;CHERCHE("~?";A1;1)-1);"")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
jee pee
Messages postés
25958
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
23 juillet 2019
5337 -
Merci. J'avais essayé le \ pour annihiler les caractères spéciaux/jokers (?,*) sans succès.
Mike-31
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
3522 -
Salut jee pee,

Excel garde quelques bottes secrètes pour jouer avec les nerfs des Excellistes, mais à tous on arrive à percer ses nébuleuses
Cordialement
Commenter la réponse de Mike-31
Messages postés
138
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
14 mars 2019
3
0
Merci
Merci a toi jee pee , ça marche super
Commenter la réponse de nihcoc