Fonction excel pour une cellule qui contient au moins un des caractères d'une au [Résolu]

- - Dernière réponse :  Guillaume - 18 déc. 2018 à 20:51
Bonjour,

Tout d'abord désolé pour ce titre à rallonge mais je ne savais pas comment le formuler. Aussi, étant novice sur les forums, je m'excuse si je ne suis pas au bon endroit.

Mon problème consiste à trouver une formule qui puisse me donner un résultat précis selon plusieurs conditions. Je m'explique :

J'ai un tableau à 3 colonnes (A,B,C) :

- A1 = 1N

- B1 = N

- C1 = Gagné ou Perdu (c'est là que ça se passe)

Je voudrais qu'en C1, le résultat gagné ou perdu s'affiche automatiquement selon B1. Tout en sachant que si B1 contient l'un ou l'autre des caractères présents en A1, le résultat est considéré comme gagné.

Alors je connais quelques formules de base, donc j'avais commencé par celle-ci :

=SI(E10=D10;"Gagné";"Perdu")

Formule qui fonctionne très bien si je n'ai qu'un seul caractère en A1 (par exemple 1).

Mais comme parfois A1 contient 2 caractères, cela ne fonctionne plus.



Voilà, j'espère avoir été clair dans ma demande.

Merci par avance.

Cordialement,

Guillaume
Afficher la suite 

1 réponse

Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842
0
Merci
Bonjour
voyez avec:

=SI(B1="";"";SIERREUR(SI(TROUVE(B1;A1); "gagné");"perdu"))

notez que TROUVE tient compte de la casse (différencie majuscule et minuscule). Si vous voulez annuler cette distinction, utilisez CHERCHE au lieu de TROUVE

crdlmnt

Haha ça fonctionne nickel !!
Merci beaucoup ! Et merci de cette réponse aussi rapide !!!!

Cordialement,
Guillaume
Commenter la réponse de Vaucluse