Menu

Compter

- - Dernière réponse : teoshrek
Messages postés
5
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
18 janvier 2019
- 18 janv. 2019 à 13:14
Bonjour,

Dans une ligne excel je voudrais compter le nombre de cellules qui se touche ayant le même référence

A1 a2 a3 a4 a5 a6 a7 a8 a9 a10 a11 a12
Re ek rp ek ek rp rp ek rp rp ek rp

Ci dessus je voudrais compter le nombres de fois que les cellules qui se touche contiennent rp, soit 2 fois a6 a7 et a9 a10

Merci

Configuration: Android / Chrome 71.0.3578.98
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
23320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2019
5552
1
Merci
Bonjour
vous ne dites pas si il peut y avoir plus de deux fois la même référence dans des cellules successives
cette formule pourrait compter le nombre de groupe de 2 successifs dans un champ A1:AA1:
à condition que A1 ne soit pas vide

=SOMMEPROD((A1:Z1=B1:AA1)*(B1:AA1<>""))

compte 1 si par exemple B - B
compte 2 si B - B - B
compte 3 si B - B - B -B

elle ne fait bien sur pas la différence entre les références et comptent toutes celles contiguës dans les conditions ci dessus
crtdlmnt


Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56663 internautes nous ont dit merci ce mois-ci

eriiic
Messages postés
22294
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 janvier 2019
7142 -
Bonjour,

cjoint.com et coller ici le lien fourni
eric
Bonjour,

Merci pour l info voici le lien
https://www.cjoint.com/c/HLtk3g4iAqX
Cld
Vaucluse
Messages postés
23320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2019
5552 -
avec une petite combine:

feuil1 en AH2:
='2'!C2

et la formule, pour compter les 5:
=SOMMEPROD((SI(C2:AG2=AH2;C2:AG2=D2:AH2))*1)

attention, cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule
crdlmnt
teoshrek
Messages postés
5
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
18 janvier 2019
> Vaucluse
Messages postés
23320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2019
-
Bonjour et meilleurs vœux à vous,

je reviens vers vous car votre formule fonctionne et je vous en remercie, mais si la cellule C2 de la feuille 2 n'est pas (RP) la formule inscrit "0" au lieu de 4 "RP" doubles. Quelle serait la formule pour lui faire compter les "RP double de la feuille "1 & 2" même si la première cellule de la feuille "2" n'est pas un RP

Merci

le lien pour voir le fichier est :

https://www.cjoint.com/c/IAijY4Ef04A
teoshrek
Messages postés
5
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
18 janvier 2019
-
Merci a vous je vais tester cela
Commenter la réponse de Vaucluse
0
Merci
Bonjour et meilleurs vœux à vous,

je reviens vers vous car votre formule fonctionne et je vous en remercie, mais si la cellule C2 de la feuille 2 n'est pas (RP) la formule inscrit "0" au lieu de 4 "RP" doubles. Quelle serait la formule pour lui faire compter les "RP double de la feuille "1 & 2" même si la première cellule de la feuille "2" n'est pas un RP

Merci
Commenter la réponse de teoshrek
Messages postés
5
Date d'inscription
mardi 18 décembre 2018
Dernière intervention
18 janvier 2019
0
Merci
le lien pour voir le fichier est :

https://www.cjoint.com/c/IAijY4Ef04A
Commenter la réponse de teoshrek