Formulation d'une formule avec des recherches verticales

Messages postés
43
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 août 2019
- - Dernière réponse : Mike-31
Messages postés
16920
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 août 2019
- 11 déc. 2018 à 15:41
Bonjour, je me suis bâti un onglet pour trouver mes coûtants car présentement j'ai les vendants et les marges de profit.

Dans mon fichier, je vais chercher mes données de ma feuille de vendant et l'autre dans marge de profit mais mas formulation n'est pas bonne car j'obtiens comme résultat : #N/A. C'est probablement une affaire de parenthèses le problème mais je ne trouve pas. Je suis habituée à faire des recherches verticales car j'en fais couramment.

Voici ce que j'ai écrit comme formule : =RECHERCHEV($B399;Arrangé!$B$7:$O$1280;3;FAUX)*(1-(RECHERCHEV($B399;'PB %'!$B$7:$P$643;3;FAUX)))

B399 est le nom de ma cellule dont je fais référence.

Comme raisonnement : je vais chercher ma donnée de vendant X (1 - pourcentage) (ex: 50,000$ X (1-10%) ce qui me donne 45,000 $.

Est-ce que quelqu'un peut m'aider S.V.P.

Merci beaucoup à l'avance ! Sylvie
Afficher la suite 

2 réponses

Messages postés
16920
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 août 2019
3562
0
Merci
Bonjour,

difficile de comprendre, Le mieux est de créer un exemple de fichier anonymisé et le joindre à la discussion afin que l'on puisse te guider
pour joindre ton fichier
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint

dans le même style tu as https://mon-partage.fr/
Commenter la réponse de Mike-31
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
46
0
Merci
Bonjour,
La formule est correcte et fonctionne pour moi. Est-ce que la valeur recherchée est bien présente dans les deux tableaux et est-ce que les valeur renvoyé (3ème colonne de la zone de recherche) sont bien des valeurs numérique (pas au format texte) ?
Mike-31
Messages postés
16920
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 août 2019
3562 -
Salut,
laisse venir sont fichier, ce sera plus facile
cordialement
Commenter la réponse de didibonf