Menu

Copie d'une formule avec décalage [Résolu]

Messages postés
2
Date d'inscription
lundi 10 décembre 2018
Statut
Membre
Dernière intervention
10 décembre 2018
- - Dernière réponse : Vaucluse
Messages postés
23966
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 mai 2019
- 10 déc. 2018 à 17:51
Bonjour
Merci de m’accueillir sur le forum.
J'ai lu plusieurs posts sur ce forum, mais je ne trouve pas de réponse à mon problème, donc je me permet de vous demander de l'aide.
J'ai une colonne ou je dois recopier une formule mais d'une ligne à l'autre j'ai un décalage de 4 lignes chaque fois.
exemple:
en M5: =SI(B5="pm";SI(C5<"12h00";C5);SI(B6="pm";SI(C6<"12h00";C6;0)))
en M6: =SI(B9="pm";SI(C9<"12h00";C9);SI(B10="pm";SI(C10<"12h00";C10;0)))
en M7: =SI(B13="pm";SI(C13<"12h00";C13);SI(B14="pm";SI(C14<"12h00";C14;0)))

etc.....

je voudrais "tirer cette formule sur une trentaine de lignes mais cela ne me décale les "b et c" que d'une ligne chaque fois.

j'ai essayer la fonction "décaler" mais je ne parviens pas au résultat recherché.

Merci de votre aide

Domdom0117
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23966
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 mai 2019
4588
0
Merci
Bonjour
remplacer B5 par:
INDIRECT("B"&LIGNE($A5)*4-15)
B6 par:
INDIRECT("B"&LIGNE($A5)*4-14)
C5 par
INDIRECT("C"&LIGNE($A5)*4-15)
C6 par
INDIRECT("B"&LIGNE($A5)*4-14)

crdlmnt
Domdom0117
Messages postés
2
Date d'inscription
lundi 10 décembre 2018
Statut
Membre
Dernière intervention
10 décembre 2018
-
Merci beaucoup, je n'aurais jamais trouvé cela tout seul !!! ça fonctionne impeccable, j'ai toute fois changé la dernière ligne: C6.... INDIRECT("C"&LIGNE($A5)*4-14) .
je crois que j'ai compris la logique hormis le *4-14.

Merci encore pour votre rapidité
Vaucluse
Messages postés
23966
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 mai 2019
4588 -
Pour comprendre la logique, il suffit de tester progressivement la formule:
=LIGNE(A5) et tirer sur quelques lignes
=LIGNE(A5)*4 idem
=LIGNE(A5)*4-14
="C"&LIGNE(A5)*4-14
sachant que le coe INDIRECT transforme en adresse le texte obtenu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse