Menu

Arrondir, Comment faire ?

-
Bonjour,
Comment puis-je arrondir par exemple
10,33 à 10,5 et
10,66 a 1.
Ou bien
10,x à 10,50 si x<=50
10,x à 11 si 50<x<100


Configuration: Android / Chrome 65.0.3325.109
Afficher la suite 

Votre réponse

3 réponses

Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
466
0
Merci
Bonsoir

En A1 le nombre à arrondi

En B1 la formule (pas de limite à 100 au delà de 50 puisque rien d'indiquer pour les nombres au dessus de 10) :

=SI(A1<=50;ARRONDI.SUP(A1*2;0)/2;ARRONDI.SUP(A1;0))

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
8896
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 avril 2019
1934
0
Merci
Bonjour à tous les dux

Une autre
=ARRONDI(2*A2+0,5;0)/2

Cdlmnt
PapyLuc51
Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
466 -
Salutation ccm81

Tu as peut être bien raison je n'ai peut-être pas bien compris la deuxième partie de la question de Guudy

""Ou bien
10,x à 10,50 si x<=50
10,x à 11 si 50<x<100
""

Cordialement
Commenter la réponse de ccm81
Messages postés
8896
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 avril 2019
1934
0
Merci
Salut PapyLuc51

Tu as peut être bien raison ...
Je pense que toi aussi, c'était juste pour en proposer une autre.
Au passage, il faut modifier la mienne pour traiter correctement les valeurs entières
=ARRONDI(2*A2+0,499999;0)/2

Bonne fin de journée
Commenter la réponse de ccm81