Menu

Recherche inversée (ou pas en fait...) [Résolu]

Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
- - Dernière réponse : gl0ugl0u
Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
- 5 déc. 2018 à 07:55
Bonjour,

Par avance je m'excuse pour le titre trompeur, il ne s'agit par réellement d'une recherche inversée, mais je ne trouve pas du tout la bonne fonction à appliquer. Je m'explique :


Ma colonne A liste la totalité des articles de ma base, matière brut comme produit fini. Je souhaite obtenir, si disponible, ce qui est renseigné en B dans la colonne C. Dans le cas si dessus, je devrais voir apparaitre l'équivalent de A2 en C3.

J'ai bien entendu appliqué =recherchev(A3;B:B;1) mais cela me donne en résultat A3 et non A2.

Je vous remercie par avance de bien m'aider à régler ça, j'ai bien tenté avec EQUIV et INDEX mais je ne pense pas avoir compris le fonctionnement des deux fonctions combinées.

Peace
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
Messages postés
22249
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 décembre 2018
1
Merci
Bonjour,

moi non plus :-)
Tu dis que tu veux B, que ça doit te faire apparaitre A2 (?!?) donc tu recherches A3 (re ?!?) pour ça...
C'est qui ton dealer que je ne lui prenne rien ?
eric

Merci eriiic 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM a aidé 31022 internautes ce mois-ci

Commenter la réponse de eriiic
Messages postés
9952
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
7 décembre 2018
0
Merci
Bonsoir

Absolument rien compris !!

Primo plutôt qu'une image inexploitable poste un exemple de ton fichier sur cjoint.com,, fais créer un lien que tu copies et redeviens coller ici
Secundo donnes 2 ou 3 exemples précis des cas qui peuvent se présenter et des résultats alors attendus

Cdlmnt
Via
Commenter la réponse de via55
Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
0
Merci
Merci pour votre retour, je pensais avoir été explicite

J'ai donc hébergé un exemple ici https://www.cjoint.com/c/HLfe1bRQZjp

Colonne A : tous mes articles (matière brut + produit fini)
Colonne B : matière brut
Colonne C : produit fini

Les colonnes A et B sont renseignées manuellement. Le but de la formule dans la colonne C est de vérifier si B est renseigné, alors renvoyer A dans la bonne cellule de C.
En exemple dans le fichier pour le résultat obtenu en C11

B9 = 000010, donc on recherche la cellule 000010 dans la colonne A (ici A11) et on renseigne A9 en C11.
Commenter la réponse de gl0ugl0u
Messages postés
23144
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2018
0
Merci
Bonjour (salut les copains!)
trouver la ligne ou A existe en B et ressortir si oui la valeur de A sur la ligne trouvée
en C2
=SIERREUR(INDEX(A:A;EQUIV(A2;B:B;0));"")
crdlmnt
gl0ugl0u
Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
-
Bonjour, c'est parfait, merci d'avoir réussi à me décrypter ^^
Commenter la réponse de Vaucluse