Menu

SOMME.SI.ENS [Résolu]

Messages postés
112
Date d'inscription
mardi 24 avril 2012
Dernière intervention
4 décembre 2018
- - Dernière réponse : YameFAZE
Messages postés
112
Date d'inscription
mardi 24 avril 2012
Dernière intervention
4 décembre 2018
- 4 déc. 2018 à 09:18
Bonjour,

J'ai trois colonnes dans une feuille de calcul. Une colonne B avec une liste déroulante, une colonne E avec une autre liste déroulante, et une colonne K avec des valeurs. Et puis j'ai deux cellules, une cellule R3 qui contient "Cartes bleues", et une cellule S4 qui contient "Frais".

Je souhaiterais faire la somme des valeurs de la colonne K pour chaque ligne qui contient à la fois "Cartes bleues" dans la colonne B et "Frais" dans la colonne E.

Excel m'informe qu'il y a une erreur au niveau du critère de recherche S4. Je ne comprends pas pourquoi. Pourtant "Frais" se situe bien dans la cellule S4. Mais visiblement S4 ne lui plaît pas. Il me marque #VALEUR! dans la cellule qui contient la formule... quelqu'un peut-il m'aider svp ? Merci d'avance.

=SI(SOMME.SI.ENS(K3:K99; B3:B99; R3; (E3:E99; S4); )=0; ""; SOMME.SI.ENS(K3:K99; B3:B99; R3; (E3:E99; S4); ))

Configuration: Ordinateur portable ASUS UX21E
Windows 7
Afficher la suite 

Votre réponse

2 réponses

Messages postés
1472
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
13 décembre 2018
0
Merci
Bonjour,

Essayer avec Ceci:
=somme.si.ens(K:K;B:B;R3;E:E;S4)

Juste avec ça ça devrait suffire

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Commenter la réponse de diablo13800
Messages postés
23175
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 décembre 2018
0
Merci
Bonjour
enlever simplement les parenthèses qui encadrent (E3:E99; S4); et supprimer le dernier point virgule
Info:
pour simplifier la formule, et enlevez la première condition, vous pouvez désactiver l'affichage des 0 plutôt que de le transformer en "":
clic sur onglet"FICHIER" dans le ruban
en bas : option
à gauche "option avancée"
et , vers le bas de la liste, décochez: "afficher un 0 dans les cellules de valeurs nulle"
crdlmnt

YameFAZE
Messages postés
112
Date d'inscription
mardi 24 avril 2012
Dernière intervention
4 décembre 2018
-
Super ça fonctionne. Merci beaucoup.
Commenter la réponse de Vaucluse