Menu

Compter nombre de cellules selon critères [Résolu]

Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
-
Bonjour,

J'ai un tableau excel dont je vous joins un extrait. J'ai deux colonnes dans lesquelles il y a un menu déroulant. Les cellules de ces colonnes comportent soit une date, soit du texte choisi dans le menu déroulant, soit rien.
J'aimerais pouvoir compter le nombre de cellules vides et comportant du texte (NON MAJ et ABSENT).

J'ai essayé avec la formule =NBVAL(plage de cellules; "NON MAJ"; "ABSENT"; " ") mais elle ne fonctionne pas.
Quelqu'un peut-il m'aider s'il vous plaît?
Merci d'avance.
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
1765
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
8 décembre 2018
1
Merci
Bonjour

NBVAL(plage de cellules) donne le nombre de cellules non vides donc pas adaptée à ta demande.

un essai :

=NB.SI(M3:N139;"NON MAJ")+NB.SI(M3:N139;"ABSENT")+NB.SI(M3:N139;"")

En espérant avoir compris

Cordialement

Merci PapyLuc51 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM a aidé 33618 internautes ce mois-ci

hernie55
Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
-
Merci pour ta réponse mais cela ne fonctionne pas, le résultat renvoyé est incorrect.
En fait, je souhaite compter par colonne (M puis N) le nombre de cellules comportant "NON MAJ" + "ABSENT" + "VIDES" pour connaître le nombre de documents restant à mettre à jour.
Commenter la réponse de PapyLuc51
Messages postés
1765
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
8 décembre 2018
1
Merci
Bonjour

Il suffit d'adapter la formule pour avoir le résultat par colonne

En M140
=NB.SI(M3:M139;"NON MAJ")+NB.SI(M3:M139;"ABSENT")+NB.SI(M3:M139;"")

incrémenter la formule vers la droite

Maintenant la formule ne donne pas les endroits où il faut agir pour mettre à jour ; ne serait-il pas plus utile de mettre en place une coloration des cellules par MFC ?
Si oui : sélectionner toute la zone (de M3 à N139) - ouvrir la fenêtre des MFC - choisir le dernier "Utiliser une formule pour........" - mettre cette formule :

=OU(M3="NON MAJ";M3="ABSENT";M3="")

Choisir le format - OK - OK

Cordialement

Merci PapyLuc51 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM a aidé 33618 internautes ce mois-ci

hernie55
Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
-
PapyLuc51, merci pour ces derniers elements, j'avais bien testé la formule =NB.SI(M3:M139;"NON MAJ")+NB.SI(M3:M139;"ABSENT")+NB.SI(M3:M139;"") mais le résultat renvoyé est incorrect. Il indique 27 alors qu'il y a beaucoup plus de Non mis à jour, absent et vide.
Je ne cherche pas à obtenir les endroits à mettre à jour. J'ai besoin de savoir combien de dossiers ne sont pas à jour à des fins statistiques.
Je ne comprends vraiment pas pourquoi ta formule ne fonctionne pas. Est-ce que ça peut être lié au fait qu'il y ait un menu déroulant?
PapyLuc51
Messages postés
1765
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
8 décembre 2018
-
Bonsoir,
Peut-être remplacer NON MAJ et ABSENT par la référence des cellules qui font partie de la liste déroulante installée.

Ou en modifiant la formule :
=SOMME(NB.SI(M3:M139;"NON MAJ");NB.SI(M3:M139;"ABSENT");NB.SI(M3:M139;""))

Cordialement
hernie55
Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
-
Merci PapyLuc, malheureusement je n'ai pas eu plus de chance avec la formule en Somme.
Avec la formule en NB.SI, il me compte bien les cellules vides. Donc le problème vient bien du fait qu'il y a un menu déroulant. Je peux pas compter avec chaque référence de cellules car cela peut évolué, un dossier non mis à jour aujourd'hui peut l'être demain.
Je continue de chercher
PapyLuc51
Messages postés
1765
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
8 décembre 2018
-
Peux-tu mettre en copie un bout de ton fichier sans donnée confidentielle sur cjoint et tu viens coller le lien obtenu sur la prochaine réponse.
https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

Cordialement
hernie55
Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
-
J'ai trouvé ! Faut mettre * après Non Maj et Absent
Commenter la réponse de PapyLuc51
Messages postés
20
Date d'inscription
lundi 29 octobre 2018
Dernière intervention
11 décembre 2018
0
Merci
Je n'arrive pas à joindre le fichier. Mes données sont dans les colonnes M et N lignes 3 à 139. Les dates inscrites dans les cellules ne font pas partie pas choix du menu déroulant. Je crois que j'ai tout dit, j'espère être claire et que quelqu'un pourra m'aider.
Commenter la réponse de hernie55