Menu

Renvoi nombre de date par mois [Résolu]

- - Dernière réponse :  eric - 1 déc. 2018 à 17:40
Bonjour,

j ai un soucis avec les dates, mes dates (jj/mm) dans la col A. et voudrai qu en B, il me donne le nombre de date pour janvier par exemple.

merci

Configuration: Android / Chrome 70.0.3538.110
Afficher la suite 

Votre réponse

4 réponses

Messages postés
489
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
36
0
Merci
Bonjour,

Pour janvier 2018, par exemple :

=NB.SI.ENS(A:A;">=01/01/2018";A:A;"<01/02/2018")

Cordialement.

Daniel
bonjour,
Merci pour votre réponse cependant si je l entre pour janvier et que dans la colonne A des cellules sont vides, il en tient compte et les additionne aussi
danielc0
Messages postés
489
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
36 -
Microclimat ? Ca fonctionne ici :



Daniel
Commenter la réponse de danielc0
Messages postés
16879
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 avril 2019
5100
0
Merci
Bonjour,

tu as aussi

=SOMMEPROD((MOIS(A2:A30)=1)*(A2:A30<>""))
bonjour,

Merci elle fonctionne très bien
Commenter la réponse de Mike-31
Messages postés
15787
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 avril 2019
3655
0
Merci
Bonjour

en fait
=SOMMEPROD((MOIS(A1:A15)=1)*(NON(ESTVIDE(A1:A15))))

pour Mike:
bonjour
la valeur "" ne suffit pas, il faut tester avec "estvide" (me demande pas pourquoi !!!)
regarde cette tite démo
https://mon-partage.fr/f/QQa4BXsv/

danielc0
Messages postés
489
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
36 -
Bonjour,
La formule dans le classeur exemple est incorrecte.
=SOMMEPROD((MOIS(A1:A15)=1)*(A1:A15<>""))
renvoie 11.

Daniel
Mike-31
Messages postés
16879
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 avril 2019
5100 -
Salut Michel_m

Je crois que Daniel a répondu, dans ta formule
=SOMMEPROD((MOIS(A1:A15=1)*(A1:A15<>"")))

il manque une parenthèse pour encadre MOIS(A1:A15)=1
ce que tu as fait =SOMMEPROD((MOIS(A1:A15)=1)*(NON(ESTVIDE(A1:A15))))

=SOMMEPROD((MOIS(A2:A34)=1)*(A2:A34<>""))

Mais t'inquiète ça m'arrive également et ça permet d'échanger amicalement
Cordialement
Commenter la réponse de michel_m
Messages postés
489
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
36
0
Merci
Sois aussi conscient de la différence entre ma formule et les deux autres solutions. La première compte les dates de janvier 2018. Les autres comptent les dates de janvier, toutes années confondues. Après tout, c'est peut-être ce que tu veux ?

Daniel
oui merci de toute façon je ferai un nouveau classeur par an
Commenter la réponse de danielc0