Menu

Systéme setup

- - Dernière réponse :  jns55 - 3 déc. 2018 à 23:03
Bonsoir,

Dans le menu Grub j'ai "système septup" qui donnait sur le bios qui ne fonctionne plus, je voudrais savoir comment je pourrais faire pour le rétablir.

Je vous remercie d'avance de vos réponses.

Configuration: Linux / Firefox 63.0
Afficher la suite 

Votre réponse

4 réponses

Messages postés
28650
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 décembre 2018
0
Merci
Bonjour,

Tu peux te référer à cette discussion (notamment la réponse de "sourcejedi").

Sinon, avant que grub s'affiche, tu es sensé voir un message apparaître à l'écran te disant sur quelle touche appuyer pour y accéder (souvent l'une de ces touches : F1, F2, F10, suppr, en fonction du modèle de carte mère).

Bonne chance
Commenter la réponse de mamiemando
0
Merci
Bonsoir,

Je suis désolé je ne comprends pas l'anglais.
mamiemando
Messages postés
28650
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 décembre 2018
-
Si tu utilises chrome/chromium il te propose sans doute de traduire la page, sinon tu peux copier coller le texte dans google translate.
Commenter la réponse de serge
0
Merci
Bonjour;
Tu as essayé de faire un
sudo update-grub 
?

C'est le script
/etc/grub.d/30_uefi-firmware
qui ajoute automatiquement cette entrée à grub. Il est lancé automatiquement à chaque fois qu'on exécute la commande update-grub.
Il faudrait regarder son contenu mais je doute que ce soit compréhensible pour quelqu'un qui ne fait pas de programmation.

exemple :

prefix="/usr"
exec_prefix="/usr"
datarootdir="/usr/share"

export TEXTDOMAIN=grub
export TEXTDOMAINDIR="${datarootdir}/locale"

. "${datarootdir}/grub/grub-mkconfig_lib"

efi_vars_dir=/sys/firmware/efi/vars
EFI_GLOBAL_VARIABLE=8be4df61-93ca-11d2-aa0d-00e098032b8c
OsIndications="$efi_vars_dir/OsIndicationsSupported-$EFI_GLOBAL_VARIABLE/data"

if [ -e "$OsIndications" ] && \
[ "$(( $(printf %x \'"$(cat $OsIndications | cut -b1)") & 1 ))" = 1 ]; then
LABEL="System setup"

gettext_printf "Adding boot menu entry for EFI firmware configuration\n" >&2

onstr="$(gettext_printf "(on %s)" "${DEVICE}")"

cat << EOF
menuentry '$LABEL' \$menuentry_id_option 'uefi-firmware' {
fwsetup
}
EOF
fi


Toujours faire un
sudo update-grub
pour faire prendre les modifs en compte.

Et il suffit de rendre le fichier non-exécutable pour supprimer l'entrée du menu grub. Personnellement je ne trouve pas que c'est une bonne idée l'ajout de cette entrée car elle risque d'inciter des gens non compétents à faire des modifications dans les paramètres de l'uefi et au redémarrage suivant... surprise !
Commenter la réponse de jns55
0
Merci
J'ai essayé, cela ne fonctionne pas.

Dans le menu grub 2.02 j'ai changé l'ordre de démarrage, j'ai mis Windows 10 en premier.Peut être est-ce cela qui a causé ce problème.
Dans le menu grub 2.02 j'ai changé l'ordre de démarrage, j'ai mis Windows 10 en premier.Peut être est-ce cela qui a causé ce problème.

J'en doute mais tu peux essayer de remettre comme au départ pour en avoir le coeur net.
Commenter la réponse de serge