Menu

Fonction SI / Remplacer une colonne

Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
-
Bonjour,

Je sollicite votre aide urgemment (j'ai besoin d'une solution pour demain matin).
Il s'agit d'une formule qui me paraissait pourtant simple...

Voila, j'aimerais que, si la valeur de la cellule A1 apparait dans la colonne D, alors la valeur correspondante en E apparaissent, sinon la valeur A1 ne change pas.

Je dois absolument utiliser la fonction SI, (bah oui, remplacer par serait trop simple...), et que cela soit appliquable à la colonne entière.

Voilà ma formule, qui ne fonctionne pas... (ca me parait pourtant bien logique, non? )

=SI(A:A=D:D;E:E;A:A)

Exemple:


A1 36 A1 36
A2 A2 A8 11
A3 A3 A11 15
A4 A4
A5 A5
A6 A6
A7 A7
A8 A8
A9 A9
A10 A10
A11 A11
Afficher la suite 

Votre réponse

5 réponses

Messages postés
56937
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
10 décembre 2018
0
Merci
Bonjour,

Les réponses sont données gratuitement par des bénévoles, selon leurs compétences et dans le temps libre dont ils disposent. Pour les vraies urgences, il est recommandé de consulter un professionnel.
Commenter la réponse de Chris 94
Messages postés
261
Date d'inscription
mardi 5 juin 2018
Dernière intervention
8 décembre 2018
0
Merci
Bonjour,

De toute façon, la valeur de A1 ne peut pas changer selon la valeur de A1. C'est une référence circulaire. De plus, je n'ai rien compris à ton exemple.

Daniel
Commenter la réponse de danielc0
Messages postés
16665
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 décembre 2018
0
Merci
Bonsoir,

et si tellement urgent un exemple de fichier anonymisé sur lequel on pourra travailler sera plus utile qu'une capture écran et nous obliger de créer un fichier à ta place pour essayer de comprendre et tester des formules
Pour joindre éventuellement un fichier

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint

dans le même style tu as https://mon-partage.fr/
MMMMMM542312
Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
-
Top! Merci! Je ne pensais pas que cela était possible...
Commenter la réponse de Mike-31
Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
0
Merci




Voila, j'aimerais que, dans la colonne B, si la valeur de la cellule A1 est dans la colonne D, alors la valeur correspondante en E apparaisse, sinon seul la valeur de A1 apparait.

J'ai tenté 2 formules, mais aucune des deux ne fonctionnent:


=SI(A:A=D:D;E:E;A:A) ne fonctionne que sur la première ligne

2ème formule:

=SI(A1=D$1:D$3;E$1:E$3;A1) ne fonctionne que sur les 3 premières lignes


https://www.cjoint.com/c/HKBuWo82IyL
Commenter la réponse de MMMMMM542312
Messages postés
16665
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 décembre 2018
0
Merci
Re,

En B1 colle cette formule voir si c'est ce que tu cherches

=SIERREUR(RECHERCHEV(A1;$D$1:$E$11;2;0);A1)
Commenter la réponse de Mike-31