Menu

RechercheV dans un onglet spécifique [Résolu]

- - Dernière réponse : Mike-31
Messages postés
16704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
- 27 nov. 2018 à 20:52
Bonjour,
J'ai un classeur Excel avec 3 onglets

1onglet nommé "Jacques" avec le mot "Taille" en A1 et "1m80" en B1
1onglet nommé "Laura" avec le mot "Taille" en A1 et "1m60" en B1

1onglet nommé "Matrice", qui servira à faire afficher les critères recherchés
dans la cellule A1, je veux saisir un nom (Dans cet exemple, saisie de Jacques)
dans la cellule A2, le mot "Taille" (critère de recherche)
dans la cellule B2, le résultat recherché (dans l'exemple 1m80).

La fonction doit donc tenir compte du nom qui figure dans l'onglet matrice, pour rechercher le résultat dans l'onglet qui porte le même nom...

Merci d'avance pour vos suggestions.
Guy
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
16704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
1
Merci
Bonjour,

difficile de comprendre, Le mieux est de créer un exemple de fichier anonymisé et le joindre à la discussion afin que l'on puisse te guider
pour joindre ton fichier
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint

dans le même style tu as https://mon-partage.fr/

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 37095 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Mike-31
Messages postés
358
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
17 décembre 2018
1
Merci
Bonjour,
Essayez ça en B2 :
=RECHERCHEV(A2;INDIRECT(A1&"!A:B");2;0)
Si il y a des espaces dans les noms de feuilles :
=RECHERCHEV(A2;INDIRECT("'"&A1&"'!A:B");2;0)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 37095 internautes nous ont dit merci ce mois-ci

Commenter la réponse de didibonf
1
Merci
Bonjour Mike,
Lien ci-dessous, pour exemple de fichier.
La fonction est à coller dans la cellule B1 de l'onglet Matrice.
Elle doit rechercher, en fonction du prénom dans la cellule A1 , la taille correspondante figurant dans l'onglet du prénom concerné.
Dans l'exemple, le résultat recherché est 1m80.

https://www.cjoint.com/c/HKBqgbsslOG

Merci d'avance

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 37095 internautes nous ont dit merci ce mois-ci

didibonf
Messages postés
358
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
17 décembre 2018
-
Je confirme que la formule suivante fonctionne dans votre cas :
en B2 :=RECHERCHEV(A2;INDIRECT(A1&"!A:B");2;0)
Commenter la réponse de gexelpa
Messages postés
16704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re,

Une discussion est un lieu de partage et d'échange et avant de voir ton fichier j'avais songé à la fonction INDIRECT que t'a proposé didibonf que je salue et sans l'avoir testée me semble la plus appropriée
Commenter la réponse de Mike-31
0
Merci
Merci didibonf, ç'est nickel !!!
Mike_31, effectivement, ce forum est un lieu de partage et franchement, votre réactivité, à toi & didibonf, ainsi que vos connaissances sont très appréciables !
Merci à vous.
Guy
Commenter la réponse de gexelpa
Messages postés
16704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re,

si tes attentes sont satisfaites, je passe le statut de la discussion en résolu
Commenter la réponse de Mike-31