Menu

Fonction SI plusieurs conditions dans une table [Résolu]

- - Dernière réponse :  ytregaro - 26 nov. 2018 à 17:25
Bonjour,

Je voudrais utiliser la fonction SI avec plusieurs conditions de recherche dans une table, mais je n'arrive pas à trouver la bonne formulation. Merci pour votre aide :)

Exemple de table
A1 : 01/01/2019
B1 : 14/02/2019
C1 : BASSE SAISON

A2 : 15/02/2019
B2 : 30/06/2019
C2 : MOYENNE SAISON

A3 : 01/07/2019
B3 : 31/08/2019
C3 : HAUTE SAISON

etc...

Saisie de date en D1 (exemple : 30/03/2019)
Résultat en E1 : MOYENNE SAISON





Configuration: Windows / Chrome 70.0.3538.102
Afficher la suite 

Votre réponse

2 réponses

0
Merci
Je viens de trouver cette base mais pense qu'il y a certainement plus simple, surtout que mes changements de saison sont nombreux dans l'année :)

=SI(ET(D1>=$A$1;D1<=$B$1);$C$1;SI(ET(D1>=$A$2;D1<=$B$2);$C$2;SI(ET(D1>=$A$3;D1<=$B$3);$C$3;"HORS CALENDRIER")))
Commenter la réponse de ytregaro
Messages postés
15550
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2018
0
Merci
Bonjour,

=SI(OU(D1<A1;D1>B3);"hors date";INDEX(C1:C3;EQUIV(D1;A1:A3;1)))
Commenter la réponse de michel_m