Menu

Plusieurs Recherchev en vba [Résolu]

Messages postés
86
Date d'inscription
jeudi 23 août 2012
Dernière intervention
27 novembre 2018
-
Bonjour,

Je cherche à traduire les formules de "Recherchev" en vba.

(avec boucle si possible ...)

En D4, recherche dans BDAGENT, l'adresse mail dans la 6ème colonne (BDAGENT étant une plage nommée)

=SI(B4="";0;SI(ESTNA(RECHERCHEV(CNUM(DROITE(B4;5));BDAGENT;6;FAUX));"HorsPM3";RECHERCHEV(CNUM(DROITE(B4;5));BDAGENT;6;FAUX)))

En F4, recherche dans BDAGENT, l'agence dans la 4ème colonne (BDAGENT étant une plage nommée)

=SI(B4="";0;SI(ESTNA(RECHERCHEV(CNUM(DROITE(B4;5));BDAGENT;4;FAUX));"HorsPM3";RECHERCHEV(CNUM(DROITE(B4;5));BDAGENT;4;FAUX)))

En H4, recherche dans BDAGENT, TEXTE dans la 3ème colonne (BDAGENT étant une plage nommée)

=SI(G4<>"";RECHERCHEV($G4;'Tableau d''activité'!$B$1:$L$18;3;FAUX))

En H4, recherche dans BDAGENT, TEXTE dans la 2ème colonne (BDAGENT étant une plage nommée)
=SI(G4="";0;RECHERCHEV($G4;'Tableau d''activité'!$B$1:$L$18;2;FAUX))

EXCEL2010

Merci d'avance,
PYGOS69
Afficher la suite 

Votre réponse

1 réponse

Messages postés
7445
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
13 décembre 2018
0
Merci
Bonjour,

En VBA, utilises la méthode Find.
PYGOS69
Messages postés
86
Date d'inscription
jeudi 23 août 2012
Dernière intervention
27 novembre 2018
-
Bonjour,

Peux-tu m'aider stp !

Cordialement,
Patrice33740
Messages postés
7445
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
13 décembre 2018
-
PYGOS69
Messages postés
86
Date d'inscription
jeudi 23 août 2012
Dernière intervention
27 novembre 2018
-
Merci !
Commenter la réponse de Patrice33740