Menu

Message d'erreurs suite à une formule [Résolu]

Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
- - Dernière réponse : NanouBou06
Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
- 14 nov. 2018 à 21:36
Bonjour, bonjour,

je viens vous demander de l'aide, voilà ma formule comporte une erreur et je n'arrive pas à la trouver. Est-ce que quelqu'un peut m'aider. Je vous remercie par avance.

Voilà ma formule : =SI(ET(EST.PAIR(A9);B9="lundi";'Planing prévue'!$B$2;'Planing prévue'!$B$9;SI(ET(EST.PAIR(A9);B9="mardi";'Planing prévue'!$B$3;'Planing prévue'!$B$10;SI(ESTVIDE(A9);"";)))))

Lorsque je valide cette formule, un encadré apparait qui me dit "Nous avons rencontré une erreur dans cette formule, êtes vous en train de taper une formule, etc......"

Si une âme charitable veuille bien m'aider, je lui en serai reconnaissante.

Bonne Fin de journée.

Nanou
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23490
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 février 2019
5622
0
Merci
Bonjour

votre formule comprend deux partie bouclées distinctes qui traitent chacune d'un cas complet et Excel ne peut pas traiter ces deux boucles ensemble
essayez comme suit:
=SI(A9="";"";SI(ET(EST.PAIR(A9);B9="lundi");'Planing prévue'!$B$2;'Planing prévue'!$B$9)&SI(ET(EST.PAIR(A9);B9="mardi");'Planing prévue'!$B$3;'Planing prévue'!$B$10))

crdlmnt
NanouBou06
Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
-
Bonjour Vaucluse, merci pour votre réponse rapide. Ça marche presque, je m'explique : l'info se marque 2 fois dans la case où il y a la formule.
Alors je vais essayer de vous expliquer ce que je cherche à faire : j'ai dans mon classeur, 2 feuilles qui s'appellent "présence" et "planing prévue" (désolée pour les fautes je les corrigerais).
Je voudrais mettre sur la feuille "présence en D9 le planning qui se trouve dans la feuille "planing prévue", mais j'ai un planning sur deux semaines, 1 semaine paire avec des horaires et 1 semaine impaire avec d'autres horaires.
Dans la feuille de "présence", c'est mon agenda du mois en cours et suivant la semaine de ce même mois, il faudra que je puisse récupérer automatiquement sur la feuille "planing prévue" les horaires suivant la semaine paire ou impaire. Seulement nous avons dans la semaine, des horaires qui peuvent différents suivant les jours.
Je ne sais pas si j'arrive à bien m'expliquer.

Je vous mets en exemple ma feuille "planing prévue" :

Semaine Paire Arrivée Départ
Lundi 8H30 16H30
Mardi 8H30 16H30
Mercredi 8H30 16H30
Jeudi 8H30 16H30
Vendredi 8H30 16H30

Semaine Impaire Arrivée Départ
Lundi 11h30 18H30
Mardi 11h30 18H30
Mercredi 11h30 18H30
Jeudi 11h30 18H30
Vendredi 11h30 18H30

et une partie de ma feuille "présence" :


n° Date Arrivée prévue au contrat Départ prévu au contrat
semaine
44 jeudi 01-11-18 11h3011h30 Voilà ce que j'ai quand je mets votre formule
44 vendredi 02-11-18
44 samedi 03-11-18
45 dimanche 04-11-18
45 lundi 05-11-18
45 mardi 06-11-18
45 mercredi 07-11-18
45 jeudi 08-11-18

Merci de votre aide
Commenter la réponse de Vaucluse
Messages postés
23490
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 février 2019
5622
0
Merci
<difficile de voir ce qu'il se passe sans le modèle, surtout pour extrapoler ce qu'il peut arriver quand vous tirer les formules, selon les blocage avec $ ou non?
ce serait plus simple si vous pouviez déposer un fichier modèle en y ajoutant les explications sur ce que vous attendez
voyez ici:
http://mon-partage.fr
déposer le fichier, créez le lien et revenez le coller dans un prochain message
bidouiller les noms si confidentialité
à vous lire
crdlmnt

NanouBou06
Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
-
Re-bonsoir, merci énormément de votre aide, voilà le lien :

https://mon-partage.fr/f/ODi2MoQ3/

Dans l'attente, recevez mes sincères remerciements.
Vaucluse
Messages postés
23490
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 février 2019
5622 -
une solution en retour

notez que vous ne pouvez pas utiliser de code de recherche entre l'affichage en B de la feuille Présence (qui est une date numérique) et la liste des vos jours en A de Planning prévu, qui sont des textes.
La formule proposée utilise le N° du jour dans la semaine , pour définir quelle ligne du tableau doit être ressortie JOURSEM(cell;2) =1 pour lundi, 2 pour mardi etc..
et le champ INDEX est variable pour l'un ou l'autre des tableaux selon le N° de semaine
https://mon-partage.fr/f/zZApAlFR/

revenez si problème
crdlmnt
NanouBou06
Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
-
Personne très réactive et très aimable. Compliment
NanouBou06
Messages postés
16
Date d'inscription
jeudi 20 juin 2013
Dernière intervention
14 novembre 2018
-
Vaucluse, sans vous je n'y serais jamais arrivée.
Je vous remercie de votre rapidité et du temps que vous avez consacré à ma demande.

Bien cordialement et bonne soirée
Commenter la réponse de Vaucluse