Compter chaque doublons [Résolu]

Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
- - Dernière réponse : Anthelm
Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
- 4 nov. 2018 à 10:42
Bonjour,

J'aimerais faire un tableau à plusieurs lignes et colonnes, et créer une fonction pour isoler toutes les lignes en doublons et donner la quantité.

C'est à dire, si dans mon tableau, j'ai deux lignes identiques, renvoyer le résultat "quantité 2"

L'idée est de remplir un tableau avec plusieurs objets avec leurs caractéristiques, et d'avoir un résultat du genre: "type 1, dimensions, options, quantité 4" "Type 2 etc etc quantité 2"

Dois-je plutôt m'orienter vers un tableau croisé dynamique? Y a t'il une fonction qui pourrait m'aider?
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842
1
Merci
Bonjour
difficile de confirmer sans en savoir plus
à partir de EXCEL 2007
pour par exemple une base de données de colonne A à colonne E de ligne 2 à ligne 100, en F2 à adapter:
=NB.SI.ENS($A$2:$A$100;A2;$B$2:$B$100;B2;$C$2:$C$100;C2;$D$2:$D$100;D2;$E$2:$E$100;E2)
attention aux signes $
cette formule tirée sur la hauteur vous donnera à chaque ligne le nombre de lignes identiques dans toutes les colonnes
crdlmnt

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65144 internautes nous ont dit merci ce mois-ci

michel_m
Messages postés
15938
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 octobre 2019
2814 -
Bonjour,

Ca va mon ami Vaucluse ?

Dois-je plutôt m'orienter vers un tableau croisé dynamique?

apparemment Oui
Anthelm
Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
1 -
Bonjour! Je vais essayer ça, merci beaucoup
Commenter la réponse de Vaucluse
Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
1
0
Merci
En fait je pourrais utiliser une fonction CONCAT pour avoir une seule entrée texte dans une colonne:
"Type 1 1250x1000 Option1"
"Type 1 1250x1000 Option1"
"Type 2 2000x1000 Option2"

Résultat attendu (dans un autre tableau par exemple)

Type 1 1250x1000 Option1 Quantité 2
Type 2 2000x1000 Option2
Commenter la réponse de Anthelm
Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
1
0
Merci
Merci Vaucluse, c'est vraiment pas mal.

Ce qu'il faudrait que je fasse, c'est d'avoir un premier tableau pour entrer les données, puis un deuxième qui supprime les doublons. Puis, ajouter ta formule pour compter les quantités mais en affichant qu'une fois chaque élément. Des idées? :)
Commenter la réponse de Anthelm
Messages postés
152
Date d'inscription
lundi 15 octobre 2018
Statut
Membre
Dernière intervention
17 juillet 2019
1
0
Merci
Ah dans l'onglet données, filtre avancé, c'est possible de dupliquer le tableau en enlevant les doublons
Commenter la réponse de Anthelm