Somme des resultats d'une recherchev

- - Dernière réponse : Mike-31
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
- 26 oct. 2018 à 08:13
Bonjour a tous,
j'ai un probleme que je n'arrive pas a resoudre.
En gros j'ai deux tableaux de donnees et lorsque je fais une recherchev il y a plusieurs ligne qui remplisse les criteres. La recherchev ne me renvoie que sur le resultat de la case choisi dans la premiere ligne. J'aimerai afficher la somme de la case choisi de chaque lignes. Est ce possible?
Afficher la suite 

4 réponses

Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
45
0
Merci
Bonjour,
Il faut utiliser la fonction =SOMME.SI(plage;critère;somme_plage)
Plage : colonne dans laquelle faire la recherche du critère
Somme_plage : colonne dans laquelle se trouve les données à additionner
Commenter la réponse de didibonf
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
3523
0
Merci
Bonjour,

Oui certainement avec SOMMEPROD ou SOMME.SI.ENS ou SOMME.SI

mais pour cerner le problème tes explications ne sont pas très claire, il faudrait avoir un exemple de fichier

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
sur le premier fichier j'ai des dates d'appel de pieces avec des quantite:

Date demande piece Qte demande Ref pieces
25/10/2018 2 F0409666
26/10/2018 5 F0409666
27/10/2018 11 F0409193
28/10/2018 34 F0409195
29/10/2018 21 F0410342
30/10/2018 2 F0410342
31/10/2018 1 F0409667
1/11/2018 1 F0410561
2/11/2018 8 F0410562
3/11/2018 10 F0410640

sur le deuxieme fichier j'ai des etats de stock a des dates precises dans different endroit
Date Ref Qte en stock a la date Stock location
25/10/2018 F0409666 5 Paris
25/10/2018 F0409666 45 Lyon
25/10/2018 F0409193 23 Marseille
26/10/2018 F0409195 78 Paris
27/10/2018 F0410342 2 Paris
28/10/2018 F0410342 1 Lyon

Je cherche a savoir si a la date de demande piece j'en avais assez pour couvrir la quantite demandes toutes location confondues. en gros le 25/10 j'avais besoin de 2 F0409666 et il y en avait en tout ce jour la 50 en stock
Commenter la réponse de Mike-31
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
3523
0
Merci
Re,

Tu n'avais pas précisé qu'il s'agissait de deux classeurs différents ce qui change tout
essaye avec SOMMEPROD ou il faut identifier le chemin d'accès/le nom du classeur/le nom de l'onglet/et la plage de cellule ce qui sera assez lourd et la formule ressemblera à ça
=SOMMEPROD(('C:\Users\mike\Desktop\[Classeur2.xlsx]Feuil1'!$B$2:$B$20=C2)*('C:\Users\mike\Desktop\[Classeur2.xlsx]Feuil1'!$C$2:$C$20))

et il faudra à chaque ouverture du fichier accepter la mise à jour des liaisons
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Merci pour ta réponse. J'essaye ça demain matin et je te redis si ça a fonctionné.
Super ça fonctionne. Je ne connaissais pas cette fonction. Ça revient à mettre plusieurs filtre. Merci !
Commenter la réponse de Mike-31
Messages postés
16919
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 juillet 2019
3523
0
Merci
Re,

les logiciels évoluent en permanence et tu as également ce genre de formule
=SOMME.SI.ENS([Classeur2.xlsx]Feuil1!$C$2:$C$10;[Classeur2.xlsx]Feuil1!$B$2:$B$10;C2)

comme tes attentes sont satisfaites, je passe le statut de la discussion en résolu
Commenter la réponse de Mike-31