Menu

Formule excel pour calculer une moyenne [Résolu]

Messages postés
134
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
15 février 2019
- - Dernière réponse : zara70
Messages postés
134
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
15 février 2019
- 25 oct. 2018 à 21:00
Bonjour,

Je souhaite obtenir votre aide quant à une formule de calcul Excel.

J'ai un tableau comportant deux colonnes :
1 avec le matricule de la personne
1 avec une note

J'ai besoin de trouver la formule me permettant de calculer la note moyenne pour chacun des matricules, voir exemple ci-dessous :

colonne A Colonne B
A 5
B 10
C 9
B 1
A 7

J'ai besoin d'obtenir un tableau de restitution avec 2 colonnes, 1 comportant le matricule de la personne, et en 2ème colonne la moyenne calculée.

colonne A Colonne B
A (5+7)/2
B (10+1)/2
C 9/1


Avez-vous une solution ?

Merci à vous.

Cordialement,
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
Messages postés
15684
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 février 2019
3613
3
Merci
Bonjour à tous,

Pourquoi des formules + ou - compliquées?

En 5 minutes, sans se prendre la tête et écrire des formules, avec un Tableau Croisé dynamique

https://www.cjoint.com/c/HJzkf37vVS5
pour zara;

Si tu ne connais pas les TCD
https://silkyroad.developpez.com/excel/tcd/

Dire « Merci » 3

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57035 internautes nous ont dit merci ce mois-ci

Commenter la réponse de michel_m
Messages postés
1603
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
20 février 2019
537
1
Merci
Bonjour,

Vous avez une formule qui marche très bien:
-Moyenne.Si

Dans votre cas place A en D1 par exemple et écriver en E1 :
=Moyenne.Si(A:A;D1;B:B)

Avec ça ça devrait marcher
Commenter la réponse de diablo13800
Messages postés
477
Date d'inscription
mercredi 5 octobre 2016
Dernière intervention
24 novembre 2018
25
0
Merci
Bonjour,

formule à adapter :
=SOMME.SI(A1:A6;'feuille 2'!A1;B1:B6)/NB.SI(A1:A6;'feuille 2'!A1)
Bonjour Fabien et merci pour votre rapidité.
Est il possible d avoir l interprétation de la formule ? Merci
fabien25000
Messages postés
477
Date d'inscription
mercredi 5 octobre 2016
Dernière intervention
24 novembre 2018
25 -
somme.si fait la somme d'une plage en fonction d'un critère choisi
nb.si compte le nombre d'occurrence d'un critère dans une plage choisie..
je ne connaissais pas MOYENNE.SI qu'a proposé diablo qui pour le coup est simple
Commenter la réponse de fabien25000
Messages postés
134
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
15 février 2019
0
Merci
Merci beaucoup pour vos propositions qui me sont d’une grande aide.
Zara70
Commenter la réponse de zara70