Menu

Heure non ouvrées [Résolu]

Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
-
Bonjour,

Est ce que quelqu'un connait une formule qui peut m'identifier les horaires non ouvrés? sachant que les horaire non ouvrés c'est le weekend, les jours féries et la plage d'horaire entre 15h et 5h
Exemple : Si la cellule A2 contient 24/10/2018 17h00 ça envoie "Non ouvrés" dans la cellule B2
Si la cellule A2 contient 27 /10/2018 14h00 (C'est un samedi) ça envoie "Non ouvrés" dans la cellule B2
Si la cellule A2 contient 01 /11/2018 9h00 (C'est toussaint) ça envoie "Non ouvrés" dans la cellule B2
Si la cellule A2 contient 25 /10/2018 9h00 ça envoie "ouvrés" dans la cellule B2

J’espère que mon explication est claire

Je vous remercie par avance mes amis :-)

Bonne fin de journée

Cordialement,

Afficher la suite 

Votre réponse

3 réponses

Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624
0
Merci
Bonjour
il faut faire quelque part la liste des jours fériés concernés par votre tableau par exemple en Z1:Z10

si vous avez une date en A1 et l'horaire en B1:
=SI(OU(NB.SI($Z$1:$Z$10;A1);JOURSEM(A1;2)>5;B1<5/24;B1>15/24);"non ouvré"; ouvré)
attention aux signes $ pour tirer la formule et aux .. /24 des limites horaires

crdlmnt

SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
Bonjour Vaucluse,


Vous m'avez dit si l'horaire est en b1 et la date en A1 sauf que dans mon cas la dates et l'heure c'est dans la même cellule
Je n'ai pas trop compris l'histoire des limites horaires pourriez vous m'expliquer un peu plus SVP
Est ce que je peux mettre aussi la plage horaire dans une cellule pour que ça soit modifiable (dans le cas ou la plage d'horaire change je ne vais pas être obligé de la changé dans la formule mais dans un tableau comme les jour féries
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
parle de la plage horaire non ouvrées bien évidemment
Commenter la réponse de Vaucluse
Messages postés
10237
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
16 février 2019
1311
0
Merci
Bonjour

Il faut :
1) Etablir la liste des jours fériés et nommer cette plage par ex feries
2) Bâtir une formule qui si le jour tombe un samedi ou un dimanche (fonction JOURSEM(cellule;2)>5 ou un jour ferié (fonction NB.SI(feries;cellule)=1) renvoie non ouvré

Cdlmnt
Via
Vaucluse
Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624 -
Salut Via
...encore raté ......???,
Bien amicalement
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
et la plage horaire?
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
Bonjour

pardon
Vaucluse
Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624 -
pour ne pas rater vu la superposition des messages, voyez ici:
https://www.commentcamarche.net/forum/affich-35656226-heure-non-ouvrees#6
Commenter la réponse de via55
Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624
0
Merci
Bonjour
voyez si vous pouvez tirer quelque chose de ce modèle, et si difficulté, essayez de déposer le votre (tout ou partie) sur le site ou vous avez trouvé celui-ci
et revenez coller le lien ici
à vous lire
https://mon-partage.fr/f/7tBK9CD3/

crdlmnt
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
Bonjour

C'est très sympa d'avoir pris le temps de créer un fichier et me l'expliquer je te remercie infiniment,

la colonne A dans votre fichier est configurée sur ce format :jjjj/mmmm/aaaa hh:mm mais si je change de format ça ne marche plus, j'ai changé le format car dans mon fichier le format par défaut c'est jj/mm/aaaa hh:mm que dois je faire pour que ça puisse marcher sur mon fichier ?

Bien cordialement,
Vaucluse
Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624 -
Ilo n'y a aucune raison pour que le changement de format modifie les résultats
pouvez vous redéposer sur le site le modèle que vous avez modifié, pour que l'on voit ce qui se passe?
en attendant voyez ici le format modifié
https://mon-partage.fr/f/rEYipYVH/
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
J'étais entrain de vous faire une autre réponse et ça a sautée soudainement!!

J'allais vous dire que ce n'est pas le format qui pose problème au temps pour moi mais c'est les jours féries qui ne sont pas pris en compte car par exemple si vous modifiez une date qui est ouvrable sur ce fichier et mettre par exemple 25/12/2018 ça reste toujours ouvres ce n'est pas la différence entre le format des jours fériés et de la colonne à qui posent plutôt ce problème ?

Dans l'attente de vous lire

Merci :-)
Vaucluse
Messages postés
23492
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 février 2019
5624 -
exact
petite erreur dans la formule en A2 à corriger comme suit et à tirer sur la hauteur
=SI(A2="";"";SI(OU(NB.SI($E$2:$E$65;ENT(A2));A2-ENT(A2)<$D$1;A2-ENT(A2)>$D$2;JOURSEM(A2;2)>5);"non ouvré";"ouvré"))

sot donc ENT (A2) qui ressort la date à la place de A2-ENT(A2) qui ressort l'heure
avec mes excuses

si vous avez votre solution, merci de passer le sujet en résolu (menu roue dentée en haut du fil à droite du titre)
crdlmnt
SAYRO
Messages postés
101
Date d'inscription
mardi 6 mars 2018
Dernière intervention
4 février 2019
1 -
Vous êtes le meilleur je vous remercie infiniment

CDLT
Commenter la réponse de Vaucluse