Menu

Mauvaise manip dans safari [Résolu]

Messages postés
2
Date d'inscription
jeudi 10 août 2017
Dernière intervention
23 octobre 2018
- - Dernière réponse : _Ritchi_
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
- 13 janv. 2019 à 09:56
Bonjour,
suite à une mauvaise manip je n'arrive plus à avoir SAFARI en Français. C'est à dire quand j'ouvre le moteur de recherche la barre de tache est affiché en anglais.
comment revenir à la barre initiale ,
merci pour votre aide


Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847
1
Merci
Bonjour,

Regarde et applique cette solution: https://www.commentcamarche.net/forum/affich-35446135-safari-a-change-de-langue-tout-seul#4

Ritchi

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57394 internautes nous ont dit merci ce mois-ci

Merci pour la réponse mais quand la fenêtre s'ouvre il y a déjà un texte que je ne peux effacer et si je rajoute ce que tu me dis cela ne donne rien.
y a t-il autre chose à faire ?
_Ritchi_
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847 -
Etrange
Exécute ce qui est demandé (ouvrir une fenêtre Terminal et lancer la commande
defaults write com.apple.Safari AppleLanguages '(fr)'
) puis une fois cela effectué, fais moi une capture d'écran de cette fenêtre Terminal.

Au cas où, voici une aide sur:
- Comment faire une capture d'écran
- Comment partager une capture d'écran ou une photo
Note1: Sélectionner la partie intéressante et pas l'écran entier sinon l'image sera trop grande et les textes seront illisibles.
Note2: La capture d'écran doit être au format PNG afin que l'on puisse cliquer dessus pour zoomer dessus: voir explications dans la partie "Images cliquables" du second lien donné ci-dessus.
Ritchi
ça y est j'ai réussi.
merci beaucoup pour ton aide.
bonne soirée
Commenter la réponse de _Ritchi_
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847
1
Merci
Bonjour,

Weknow est une redirection du moteur de recherche et un pirate de navigateur, qui attaque Safari, Google Chrome, Mozilla Firefox. Leur site Web est configuré comme page d'accueil, comme nouvel onglet et comme moteur de recherche par défaut. Toutes les requêtes de recherche sont redirigées vers un site de pirate du web...
En résumé: "weknow" est une cochonnerie qu'il faut absolument supprimer.

Solution:
- Télécharge et installe la version gratuite de Malwarebytes
- Lance Malwarebytes
- Clique sur le bouton bleu "Scan Now"
- Patiente
- Si il te trouve une cochonnerie, alors clique sur "Confirm" pour confirmer la suppression de la cochonnerie.

Ritchi

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57394 internautes nous ont dit merci ce mois-ci

_Ritchi_
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847 -
Il y a aussi une méthode manuelle:
Étape 1 :
- Ferme Safari
- Ouvre le dossier Applications: tu devrais trouver une application nommée "weknow". Si il n'y en a pas passe à l'étape2
- Fais un clic-droit dessus et choisit "Placer dans la corbeille..." Il se peut qu'un mot de passe administrateur te soit demandé.
- vide la corbeille.

Étape2:
- ouvre le menu Pomme -> Préférences système -> Profile (si il existe)
- dans la liste des profils sur le côté gauche choisit AdminPrefs et clique sur “-” bouton pour le supprimer
- il se peut que cet AdminPrefs soit nommé différemment. Clique alors sur le nom que tu trouves et regarde si la description du profile correspond à celui-ci:


Étape3:
- Lance Safari
- Ouvre le menu "Safari -> Préférences... "
- Choisit l'onglet "Général" et modifie le champ "Page d'accueil"
- Choisit l'onglet "Extensions" et dans la liste des extensions affichées, recherche et supprime les extensions MacSaver, MacVX, MacCaptain, MacPriceCut, SaveOnMac, Mac Global Deals ou MacDeals, MacSter, MacXcoupon, Shop Brain (ou SShoP Braaiin), PalMall, MacShop, MacSmart, News Ticker Remover, Shopper Helper Pro, Photo Zoom, Best YouTube Downloader, ArcadeYum, Extended protection, Video download helper, FlashFree or GoldenBoy.
- Quand tu as fini, relance Safari

Ritchi
Commenter la réponse de _Ritchi_
0
Merci
Bonjour je me permets de poser une autre question . suite a cette mauvaise manip maintenant réparée, je ne peux ouvrir la page d'accueil d'internet qui avant était google. Maintenant il est afficher "SEARCH". et quand je vais dans préférence la page d'accueil enregistrée est "weknow". Mais il est impossible de la supprimer , je ne peux pas sélectionner cette case.
que faire ?
merci
Commenter la réponse de tiery10
0
Merci
merci mais je ne vois pas comment supprimer adminpref (il y en a 2)
quel ce bouton: “-” bouton pour le supprimer
merci
_Ritchi_
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847 -
oui
super ça fonctionne.
merci encore pour ton aide et félicitation pour tes compétences.
Commenter la réponse de tiery10
0
Merci
Bonjour Ritchi,

J'ai été victime de weknow aussi sur une MAJ de flash adobe. J'ai un macbook pro 2018, j'ai installé MalwareBytes et supprimé le malware. J'ai tout testé dans le Terminal. J'essaye donc toutes les méthodes possibles et inimaginables mais je ne trouve rien qui fonctionne... Safari et Chrome sont toujours en anglais et impossible de faire quoi que ce soit. Pour ce qui concerne cette méthode là, je ne trouve pas la catégorie "Profile" dont tu parles.. Je ne sais plus quoi faire. Peux-tu m'aider ?
Commenter la réponse de mantez
Messages postés
19642
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 janvier 2019
4847
0
Merci
Bonjour,

Vérifier l'ordre préférentiel des langues:
- taper la commande
defaults read -g AppleLanguages

- presser la touche "Entrée" (↩︎) du clavier pour activer la commande
Quelle est la réponse à cette commande ?
(si tu veux savoir comment faire une capture d'écran et la partager, regarde cette réponse)

Modifier l'ordre préférentiel des langues:
méthode 1:
- lancer la commande
defaults write com.apple.Safari AppleLanguages '(fr)'

- presser la touche "Entrée" (↩︎) du clavier pour activer la commande
- redémarrer le Mac : menu Pomme () puis "Redémarrer"
- tester Safari

méthode 2:
- lancer la commande
defaults write -g AppleLanguages '("fr-FR", "en-US")'

- presser la touche "Entrée" (↩︎) du clavier pour activer la commande
- redémarrer le Mac : menu Pomme () puis "Redémarrer"
- tester Safari

Normalement, après avoir fait cela, Safari utilise la langue désirée.

Autre piste: Si tu crains d'avoir attrapé un ou des malware(s), alors:
- télécharge et installe dans ton dossier "Applications" l'outil Malwarebytes anti-malware (gratuit)
- lance cet outil
- si le scan découvre des malwares alors active l'option de suppression puis redémarre le Mac (menu Pomme () puis "Redémarrer")

Enfin dernière piste:
Depuis le Finder:
- Clique une fois sur le menu "Aller" : les sous-menu de "Aller" apparaissent
- Appuie sur la touche Option ( ⌥ ): le sous-menu "Bibliothèque" doit apparaître dans la liste.
- Choisit ce sous-menu "Bibliothèque": une fenêtre du Finder montrant le contenu du dossier Bibliothèque apparait
- Repère et entre dans le dossier "Cache"
- Repère "com.apple.Safari": s'il existe, déplace-le sur le bureau du Finder
- Repère "com.apple.safari.cache": s'il existe, déplace-le sur le bureau du Finder
- Redémarre le Mac

Ritchi
Commenter la réponse de _Ritchi_