Menu

Formule SI

Messages postés
7
Date d'inscription
mercredi 10 octobre 2018
Statut
Membre
Dernière intervention
7 mars 2019
- - Dernière réponse : Vaucluse
Messages postés
23875
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
- 14 oct. 2018 à 18:19
Bonjour,

Ca fait un moment que je me creuse la tête pour trouver la bonne formule mais rien y fait, ça ne fonctionne pas..
Le but serait de pouvoir calculer automatiquement les heures supplémentaires de mes agents. La formule serait SI le total des heures hebdomadaires (lignes 15, 23, 31 et 37) est SUPÉRIEUR à 35 alors le surplus d'heures irait s'ajouter dans le total des heures supplémentaires (ligne 39).


Merci par avance aux âmes charitables qui voudront bien me venir en aide !

Afficher la suite 

Votre réponse

1 réponse

Messages postés
23875
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
5767
0
Merci
Bonjour

si votre format d'heure est hh:mm
=SI(SOMME(D15;D23;D31;D37)>35/24;SOMME(D15;D23;D31;D37)-35/24;0)

si votre format est décimal:
=MAX(SOMME(D15;D23;D31;D37)-35;0)

crdlmnt


Powlyne7
Messages postés
7
Date d'inscription
mercredi 10 octobre 2018
Statut
Membre
Dernière intervention
7 mars 2019
-
Oui c'est en format décimal.
Ca fonctionne! Merci beaucoup :-)
Powlyne7
Messages postés
7
Date d'inscription
mercredi 10 octobre 2018
Statut
Membre
Dernière intervention
7 mars 2019
-
Je viens de m'apercevoir que quand le total hebdomadaire dépasse 35, la formule prends en compte le total par exemple 50 et pas la différence qui est de 15..
Voici ce que je trouve :
Vaucluse
Messages postés
23875
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
5767 -
La bande rouge est à peine lisible dans votre image, et je pensais que vous comptiez les heures sup hebdomadaires.
s'il s'agit de compter les H.S sur 4 semaines, il faut multiplier 35 par le nombre de semaines dans la formule, soit donc:
=MAX(SOMME(D15;D23;D31;D37)-35*4;0)
le *4 dépendant du nombre de semaines complètes que vous prenez en compte (soit le nombre de cellule D dans la somme)
Commenter la réponse de Vaucluse