Menu

écrire une formule dans une ou plusieurs cellules [Résolu]

pactoine2 5 Messages postés jeudi 21 septembre 2017Date d'inscription 10 octobre 2018 Dernière intervention - 10 oct. 2018 à 14:53 - Dernière réponse : pactoine2 5 Messages postés jeudi 21 septembre 2017Date d'inscription 10 octobre 2018 Dernière intervention
- 10 oct. 2018 à 17:03
Bonjour,
J'aimerais solliciter votre aide:
en effet je souhaite par le moyen d'une VBA pouvoir écrire une formule dans une ou plusieurs cellules si la ou les cellules avoisinantes ne sont pas vides sinon les cellules doivent rester vierges (voir le photo)
Avec tous mes remerciements

Afficher la suite 

Votre réponse

2 réponses

danielc0 220 Messages postés mardi 5 juin 2018Date d'inscription 11 octobre 2018 Dernière intervention - 10 oct. 2018 à 15:44
0
Merci
Bonjour,

Sub test()
Dim C As Range
For Each C In [A8:A17]
  If C.Offset(, 3) <> "" Then
    C.FormulaLocal = "=SI(ESTNA(RECHERCHEV(D" & C.Row & ";Bases!B2:F370;5;0));"""";RECHERCHEV(D" & _
      C.Row & ";Bases!B2:F370;5;0))"
  End If
Next C
End Sub


Daniel
Commenter la réponse de danielc0
pactoine2 5 Messages postés jeudi 21 septembre 2017Date d'inscription 10 octobre 2018 Dernière intervention - 10 oct. 2018 à 17:03
0
Merci
MERCI DANIEL
c'est exactement ce qu'il me fallait
SUPER!!!!
a bientôt
Commenter la réponse de pactoine2