Menu

écrire une formule dans une ou plusieurs cellules [Résolu]

Messages postés
5
Date d'inscription
jeudi 21 septembre 2017
Dernière intervention
10 octobre 2018
- - Dernière réponse : pactoine2
Messages postés
5
Date d'inscription
jeudi 21 septembre 2017
Dernière intervention
10 octobre 2018
- 10 oct. 2018 à 17:03
Bonjour,
J'aimerais solliciter votre aide:
en effet je souhaite par le moyen d'une VBA pouvoir écrire une formule dans une ou plusieurs cellules si la ou les cellules avoisinantes ne sont pas vides sinon les cellules doivent rester vierges (voir le photo)
Avec tous mes remerciements

Afficher la suite 

Votre réponse

2 réponses

Messages postés
261
Date d'inscription
mardi 5 juin 2018
Dernière intervention
8 décembre 2018
0
Merci
Bonjour,

Sub test()
Dim C As Range
For Each C In [A8:A17]
  If C.Offset(, 3) <> "" Then
    C.FormulaLocal = "=SI(ESTNA(RECHERCHEV(D" & C.Row & ";Bases!B2:F370;5;0));"""";RECHERCHEV(D" & _
      C.Row & ";Bases!B2:F370;5;0))"
  End If
Next C
End Sub


Daniel
Commenter la réponse de danielc0
Messages postés
5
Date d'inscription
jeudi 21 septembre 2017
Dernière intervention
10 octobre 2018
0
Merci
MERCI DANIEL
c'est exactement ce qu'il me fallait
SUPER!!!!
a bientôt
Commenter la réponse de pactoine2