Menu

Cherche deux formules bien distinctes [Résolu]

Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
-
Bonjour,

Manquant cruellement d'une formation sur Excel, j'ai besoin de votre aide pour trouver deux formules bien distinctes afin de gagner du temps dans mon boulot

Voici ce que je remplis chaque jour manuellement, les données des colonnes A, B, C et D changeant régulièrement



1ère formule
La plus simple je pense, je cherche à remplir la colonne C depuis une extraction de l'ERP que j'utilise et que je colle dans une feuille appelée Stock. J'aimerai calculer le stock global pour une référence donnée sachant que je dispose de plusieurs entrepôts


2ème formule
Cette fois-ci, je cherche à calculer la colonne E à partir de cellules qui sont "figées" dans une feuille appelée BDD. Ces cellules ne sont pas amenées à changer, donc à l'heure actuelle je n'ai d'autres choix que d'aller sélectionner la cellule sur cette feuille.
Je pense qu'il est possible d'aller chercher l'info automatiquement, mais je n'ai pas trouver comment faire avec RECHERCHEV et SI est trop vaste pour mes connaissances.
La formule que j'utilise pour le moment est montrée sur la première image, l'arrondi supérieur étant obligatoire.


Je vous remercie sincèrement par avance du temps que vous voudrez bien consacrer à mes demandes.


Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
23185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
2
Merci
Bonjour
ce serait plus simple avec votre fichier plutôt qu'avec des images!

la 1° formule, en C2:

=SOMME.SI(Stock!A:A;A2;Stock!C:C)

et pour la seconde, en E2 (sans garanties vu la difficulté de lecture de tout ça):

=ARRONDI.SUP(D2/RECHERCHEV(A2;Bdd!A:B;2;0);0)

et pour éviter un affichage d'erreur quand A est vide:

=SIERREUR(ARRONDI.SUP(D2/RECHERCHEV(A2;Bdd!A:B;2;0);0);"")
fonctionne sur Excel >= 2007

si ça ne va pas essayez de déposer votre fichier ici
http://mon-partage.fr
et revenez coller le lien créé sur le site

crdlmnt


Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 37607 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Vaucluse
Messages postés
477
Date d'inscription
mercredi 5 octobre 2016
Dernière intervention
24 novembre 2018
1
Merci
Bonjour,
la première formule, je n'arrive pas à comprendre la relation entre les 2 images
pour la deuxième formule je partirai sur une formule en E2 du type
=ARRONDI.SUP(D2/RECHERCHEV(A2;BDD!A1:C4;EQUIV("Y";BDD!A1:C1;0);0);0)


à te lire

Commenter la réponse de fabien25000
Messages postés
9
Date d'inscription
mardi 22 mai 2018
Dernière intervention
5 décembre 2018
0
Merci
Bonjour,

Je vous remercie pour vos réponses, grâce à vous tout fonctionne comme je le souhaitais.

vous pouvez marquer le sujet comme résolu :)

Cdt
Commenter la réponse de gl0ugl0u