Menu

Compter occurences colonne valeurs sont inconnues

waaalex - 13 sept. 2018 à 13:48 - Dernière réponse : michel_m 15426 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 21 septembre 2018 Dernière intervention
- 13 sept. 2018 à 15:05
Bonjour,

J'ai un fichier excel qui liste les extension de centaines de milliers de fichiers.
Il y a potentiellement des centaines d'extensions différentes

J'ai besoin de savoir combien j'ai d’occurrence par extension.

exemple :

xxx
xyr
ddd
ddd
zes
dfr
tgy
fds
...

en resultat, je souhaiterais avoir un table de la sorte

extension nombre
ddd 2

etc.

Merci pour votre aide.


Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
titeufdu89 172 Messages postés samedi 28 juillet 2012Date d'inscription 22 septembre 2018 Dernière intervention - 13 sept. 2018 à 14:26
2
Merci
Bonjour,

Tu souhaites créer un tableau récapitulatif dans une autre feuille de ton classeur ou juste ajouter le nombre d’occurrences dans une nouvelle colonne de ton tableau sur chaque ligne?

Si tu souhaites créer un récapitulatif c'est assez simple, copie et colle la colonne des extensions dans une nouvelle feuille de ton classeur, ensuite tu sélectionnes ton tableau > "Données" > "Supprimer les doublons" (compare le colonne A)

Supposons que la colonne contenant les extensions est la colonne A de ta feuille nommée "Extension" et que tu colles la formule en B1 dans la feuille "Récap" (à ajuster si besoin) =NB.SI(Extension!A:A;A1)

Si jamais toutes cest manipulations peuvent être automatisée en VBA sans trop de difficultés.

Bonne journée

Jc

Merci titeufdu89 2

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 26505 internautes ce mois-ci

Commenter la réponse de titeufdu89
fabien25000 319 Messages postés mercredi 5 octobre 2016Date d'inscription 22 septembre 2018 Dernière intervention - Modifié par fabien25000 le 13/09/2018 à 14:16
0
Merci
Bonjour,

En admettant que les extensions soient listées colonne A, que l'on cherche le nombre d'occurence de l'extension renseignée en B1et que l'on veuille trouver le nombre d'occurence d'une extension en C1

on pourrait écrire ddd en B1 et =NB.SI(A:A;B1) en C1

Merci mais je n'ai rien en colonne B. Tout est dans la colonne A et je n'ai pas de liste exhaustive des extensions qu'il peut y avoir.
Commenter la réponse de fabien25000
michel_m 15426 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 21 septembre 2018 Dernière intervention - Modifié par michel_m le 13/09/2018 à 15:09
0
Merci
Bonjour

En 5 minutes, sans se prendre la t^te avec des formules, avec un TCD (Tableau Croisé Dynamique)...

Voir tuto "au cas où"
https://silkyroad.developpez.com/Excel/NouveautesExcel2007/#LVII


Commenter la réponse de michel_m