Menu

Formule Excel [Résolu]

IBA42 2 Messages postés samedi 11 août 2018Date d'inscription 11 août 2018 Dernière intervention - 11 août 2018 à 02:32 - Dernière réponse : IBA42 2 Messages postés samedi 11 août 2018Date d'inscription 11 août 2018 Dernière intervention
- 11 août 2018 à 09:51
Bonjour,

S'il vous plaît aidez moi, j'ai cherché mais pour le moment j' ai pas encore trouvé.
J’ai deux colonnes: A1 contenant des codes et B1 des noms et je voudrai associer à chaque nom un code bien spécifique.
Pour la première fois, je veux qu’il ait un libre choix de faire correspondre un code à n’importe quel nom quelconque.
Au fur et à mesure que je remplis les colonnes, Excel mémorise les codes et noms correspondant déjà saisie de telle sorte qu’aucun autre code ancien ne puisse être attribué à un nouveau nom autre que l’ancien.

Par exemple la première fois si je choisis le code C002 au nom Dupon alors la seconde fois si je retape C002 avec un autre nom Alex qu’ Excel ne puis pas le reconnaitre sauf si c’est un nouveau code qui n’a pas été saisie avant.
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
via55 9568 Messages postés mercredi 16 janvier 2013Date d'inscription 11 août 2018 Dernière intervention - Modifié par via55 le 11/08/2018 à 03:13
1
Merci
Bonjour

Pour interdire d'entrer 2 fois le même code en colonne A :
Selectionner toute la colonne A
Données Validation de données
Autoriser Personnalisé
et dans Formule entrer : =NB.SI(A:A;A1)<2

Cdlmnt
Via

Merci via55 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24095 internautes ce mois-ci

Commenter la réponse de via55
Raymond PENTIER 46557 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 août 2018 Dernière intervention - 11 août 2018 à 05:50
0
Merci
Bonsoir.

...et pour signaler en rouge les lignes où un même code correspond à 2 noms différents, on peut utiliser la Mise en Forme Conditionnelle.

Une colonne de concaténation des deux premières permet de vérifier s'il y a autant de données identiques en A et en C.

https://www.cjoint.com/c/HHldUNTxv0E
Commenter la réponse de Raymond PENTIER
IBA42 2 Messages postés samedi 11 août 2018Date d'inscription 11 août 2018 Dernière intervention - 11 août 2018 à 09:51
0
Merci
Bonjour,

Merci pour votre assistance, vraiment je suis satisfait.Raymont PENTIER, ta formule repond bien à ce que je cherchais, merci à tous.
Commenter la réponse de IBA42