Menu

Addition conditionnelle sur plusieurs pages [Résolu]

Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention - 8 août 2018 à 14:25 - Dernière réponse : Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention
- 10 août 2018 à 10:58
Bonjour,

J’essaie une formule un peu compliquée dans laquelle je dois faire une erreur de syntaxe, je pense.

Pour simplifier

Je souhaite additionner dans toutes les pages (onglets) nommées Page_1 à Page_100 la cellule D10 pour autant que la cellule C5 de la page contient le code 1510 autrement laissez la cellule vide.


=SOMME.SI(Page_1:Page_100!$D$10);1510;(Page_1:Page_100!$C$5);""

Merci d’avance de votre réponse

Pour info
J’ai essayé de développer une formule que j’utilise et qui fonctionne bien dans une seule feuille soit :
=SOMME.SI(E6:E384;"SEAN";F6:F384)
Formule qui m’additionne tout dans la colonne F6 à F384 pour autant qu’il y ait le code SEAN dans la colonne E


Afficher la suite 

Votre réponse

7 réponses

Meilleure réponse
Axys_CH 32 Messages postés mardi 5 juin 2018Date d'inscription 8 août 2018 Dernière intervention - 8 août 2018 à 14:32
1
Merci
alors je suis pas trop à l'aide avec exel mais il doit y avoir une fonction IF pour créer des conditions du genre IF(C5=1510, ton addition, autre chose)

Merci Axys_CH 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24794 internautes ce mois-ci

Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention - 8 août 2018 à 14:39
Merci pour la réponse. Cependant le .Si ajouté à la fonction SOMME fait le même travail que IF dans ce cas je pense.
Commenter la réponse de Axys_CH
Meilleure réponse
PapyLuc51 1712 Messages postés dimanche 3 mai 2009Date d'inscription 19 octobre 2018 Dernière intervention - 8 août 2018 à 15:34
1
Merci
Bonjour,

Un truc simple à faire :
Tu sélectionnes toutes tes pages 1 à 100 - (clic sur l'onglet page_1 touche Maj+clic sur page_100) - tu vas sur une cellule hors champs (par exemple Z10)

Là tu installes cette formule =SI($C$5=1500;$D$10;"") et tu confirmes par Enter

Sur ta feuille de récapitulation la formule =SOMME(Page_1:Page_100!$Z$10)

Cordialement

Merci PapyLuc51 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24794 internautes ce mois-ci

Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention - 9 août 2018 à 14:59
Merci beaucoup de t'être penché dessus mon problème,
Cependant, dans ta solution je dois aller mettre un sous-total (hors Champs) sur toutes les feuilles ce que je voulais éviter.
Il n'y a pas un moyen de faire le calcul en une fois dans une cellule de la feuille récapitulation?
Autrement je ferai ainsi.
PapyLuc51 1712 Messages postés dimanche 3 mai 2009Date d'inscription 19 octobre 2018 Dernière intervention - 9 août 2018 à 15:25
En attendant l'intervention des pros d'excel
Il y a une autre solution est de faire tous les calculs intermédiaires sur la feuille récapitulation dans un tableau de synthèse

Voir cette démonstration

ou encore celle-ci

Cordialement
Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention - 9 août 2018 à 17:32
OK merci
Commenter la réponse de PapyLuc51
Grandcanari 7 Messages postés mardi 7 août 2018Date d'inscription 10 août 2018 Dernière intervention - 10 août 2018 à 10:58
0
Merci
Bonjour,

Pour finir j'ai fait selon la méthode de PapyLuc51 et cela fonctionne bien
Merci encore.

Cependant je serai intéresser de connaître la méthode pour le faire directement
Bonne journée
Commenter la réponse de Grandcanari