Menu

RechercheH combiné à Concatener

xlspourlesnuls 1 Messages postés mardi 7 août 2018Date d'inscription 7 août 2018 Dernière intervention - 7 août 2018 à 16:20 - Dernière réponse : Vaucluse 22605 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 août 2018 Dernière intervention
- 7 août 2018 à 16:52
Bonjour la communauté,

Je suis assez novice sur excel et j'utilise souvent votre forum pour répondre à des problématiques que je rencontre dans mon utilisation du tableur et merci pour cela.

Dans le cadre d'un projet de groupe dans mes études, je réalise un petit tableau de suivi des ventes de boissons par mois.

J'aimerai que mes volumes soient transmis dans un autre tableau qui calcule l'évolution, le % de progression etc.

Pour récupérer les données, j'utilise typiquement la RECHERCHEH et ça fonctionne bien, sauf que j'aimerai automatiser l'actualisation quand des mois s'ajoute pour toute l'année.



Le problème c'est que j'ai une erreur N/A et que ça ne fonctionne pas ... Si j'ajoute des mois, il faut resélectionner les plages de cellules pour chaque, ce qui peut être fastidieux. Une idée simple pour résoudre ce problème ? J'ai pourtant vu des personnes y arriver.

Merci d'avance pour votre participation.
Afficher la suite 

Votre réponse

1 réponse

Vaucluse 22605 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 août 2018 Dernière intervention - 7 août 2018 à 16:52
0
Merci
Bonjour
pas tout compris, mais on va essayer

pour ressortir la valeur de la ligne 5 en prenant en compte les valeurs de 1 et 2, à condition bien sur qu'il n'y ait pas deux fois le même cas dans les colonnes:

=SOMMEPROD(($B$1:$O$1=B1)*($B$2:$O$2=B2)*($B$5:$O$5))

vous pouvez remplacer B1 et B2 par les valeurs que vous voulez détecter ou les textes entre guillemets, car cette formule vous renverra en fait le total de la colonne B en ligne 5, d'où la question: quelle utilité?

crdlmnt



Commenter la réponse de Vaucluse