Menu

Insertion automatique des codes postaux % villes [Résolu]

Alice - 7 août 2018 à 12:25 - Dernière réponse : Vaucluse 22591 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 août 2018 Dernière intervention
- 7 août 2018 à 16:44
Bonjour,

J'ai une liste de villes qui ont répondu à mon formulaire et souhaiterai voir afficher automatiquement le code postal correspondant dans la colonne d'à côté. Je dispose de 2 fichiers Excel : un premier avec les villes qui ont répondu avec les colonnes : Ville : CP : Nom : Prénom : Fonction : Courriel : (c'est justement cette colonne "CP : " que j'aimerai compléter automatiquement), les autres sont remplies ; et une 2nd fichier Excel (que je peux mettre dans une autre feuille sur le même fichier éventuellement) qui comprend les villes de France avec :
CODE INSEE (autrement dit le code postal) en Colonne L / at INSEE en colonne M / RAISON SOCIAL POUR CARRIERE (autrement dit la Ville) en colonne N

J'aimerai aller chercher dans le 2nd fichier le nom de la ville et afficher dans le 1er le code postal correspondant.

Est-ce que quelqu'un peut m'aider SVP cela fait 3h que je suis dessus avec les "RECHERCHEV" que je ne maitrise pas

En vous remerciant par avance
Afficher la suite 

Votre réponse

5 réponses

Vaucluse 22591 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 août 2018 Dernière intervention - 7 août 2018 à 13:01
0
Merci
Bonjour
vous ne pouvez pas utiliser recherche V si la colonne ville est à droite de la colonne code
essayez avec:
=INDEX(colonne code_soit L:L;EQUIV(ville cherchée;colonne ville_soit N_N;0))
que vous pouvez complèter pour éviter des affichages #N/A par:


=SIERREUR(INDEX(colonne code;EQUIV(ville cherché;colonne ville;0));"")


mais le problème reste qu'il peut en principe y avoir plusieurs codes pour la même ville

crdlmnt
Commenter la réponse de Vaucluse
AHluiycse 1 Messages postés mardi 7 août 2018Date d'inscription 7 août 2018 Dernière intervention - 7 août 2018 à 14:12
0
Merci
Voici la feuille 1 dans laquelle je souhaiterai que les codes postaux se mettent directement :



et la base Ville / Code postaux dont je dispose


Où dois-je mettre la formule exactement ?

Merci pour ce retour !

Bien à vous
Commenter la réponse de AHluiycse
Vaucluse 22591 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 août 2018 Dernière intervention - 7 août 2018 à 14:37
0
Merci
Re
avec les noms de feuille et les n° de ligne, on aurait pu être plus précis!! alors supposons que votre base est en feuil1 et que vous voulez ressortir le code en feuil2

en E2 (si la ligne Munch Nieurlet est bien sur cette ligne):

=SIERREUR(INDEX(Feuil1!L:L;EQUIV(C2;feuil1!N:N;0));"non trouvé")

crdlmnt
Un énorme merci à vous !!!! top !
Vaucluse 22591 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 août 2018 Dernière intervention - 7 août 2018 à 16:44
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse