Formule pour rechercher un nombre [Résolu/Fermé]

Messages postés
61
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
17 mai 2019
- - Dernière réponse : andy2092
Messages postés
61
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
17 mai 2019
- 25 juil. 2018 à 14:29
Bonjour,

J'ai un tableau comme ceci :


Les années sont présentes dans une liste déroulante.
Quelle formule dois-je utiliser si je veux qu'une cellule affiche le nombre correspondant à l'année quand je la sélectionne (ex : 2018 --> 1, etc) ?

J'ai essayé recherche, recherchev, rechercheh, index et equiv mais aucune de ces formules ne marche.

Merci !
Afficher la suite 

5 réponses

Messages postés
5380
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
10 décembre 2019
360
0
Merci
Bonjour


La colonne A les années
la colonne B les valeurs

=RECHERCHEV(C2;A2:B12;2;faux)
on cherche la valeur de l'année présente en cellule C2
dans la plage de cellules A2 à B12
on retourne l'information de la colonne 2 (colonne B)
on veut la valeur correspondant exactement à C2



Messages postés
27049
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
11 décembre 2019
1928
0
Merci
Bonjour,

Les deux fonctions peuvent être utilisées :




Après.... sans savoir ce que vous avez testé exactement... difficile de vous dire où vous vous êtes trompé !
Messages postés
24738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 décembre 2019
4917
0
Merci
Bonjour
si vous voulez afficher le résultat "uniquement quand vous sélectionnez la cellule" il faudra passer par VBA
et nous dire où vous voulez le résultat
crdlmnt
Messages postés
50528
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
11427
0
Merci
Si les années sont en colonne A:A tu peux utiliser la formule =A:A-2017
Si l'année est placée dans la cellule A2, ce sera la formule =A2-2017

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Messages postés
61
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
17 mai 2019
0
Merci
Merci à vous c'est parfait ! :D