Menu

Rédaction d'une formule dans vba

Messages postés
185
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
14 mai 2019
-
Bonjour,

j'ai une feuille excel dans la quelle j'ai un bouton qui remet à zéro toutes les cellules de la feuilles et réécrit les formules dans les cases où il y en as.
J'ai dans la case I46:K46 la formule ci dessous

=SI(ESTVIDE(D25);"";"FR"&TEXTE(MOD(3*MOD(GAUCHE(D25;9);97)+12;97);"00")&" "&TEXTE(GAUCHE(D25;9);"000 000 000"))

mais je n'arrive pas à écrire un code qui ait pour conséquence de remettre cette formule dans la case (si elle avait été supprimée).

Pouvez-vous m'aider.

Merci

Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
15871
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 juin 2019
2747
1
Merci
Bonjour

dans VBA tu as la méthode "formulalocal" , membre le l'objet "range" qui permet décrire ta formule tel quel que tu l'as écrite dans excel

range("X3").formulalocal="=taformule"

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 43965 internautes nous ont dit merci ce mois-ci

Commenter la réponse de michel_m