Menu

Fonction SI comprise entre plusieurs valeurs [Résolu]

pesellier 6 Messages postés mardi 15 novembre 2016Date d'inscription 11 juillet 2018 Dernière intervention - 11 juil. 2018 à 09:11 - Dernière réponse : Vaucluse 22398 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 juillet 2018 Dernière intervention
- 11 juil. 2018 à 12:15
Bonjour,

Je me permets de solliciter votre aide.

Mon objectif est que si la valeur contenue en colonne D est comprise entre - 2 et 2 et si la valeur contenue en colonne E est comprise entre -10% et 10%, alors la valeur de la colonne D devra remontée en colonne F et la valeur de la colonne E devra remontée en colonne G.

S'il est possible de ne pas passer par une macro, cela m'arrangerait.

Le fichier dispo au lien suivant : https://cjoint.com/c/HGlhcl5ll7N

Franchement bravo (et merci!) pour résoudre ce casse-tête.
Afficher la suite 

Votre réponse

5 réponses

Vaucluse 22398 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 juillet 2018 Dernière intervention - Modifié par Vaucluse le 11/07/2018 à 10:32
0
Merci
Bonjour
il n'y a malheureusement, à première vue, aucune ligne de votre exemple qui remplissent les conditions
votre fichier en retour avec en F et G les formules correspondant à ce que vous demandez, et une ligne en rouge rajoutée pour vérifier le fonctionnement
https://mon-partage.fr/f/XeJkg3T2/
crdlmnt
Commenter la réponse de Vaucluse
pesellier 6 Messages postés mardi 15 novembre 2016Date d'inscription 11 juillet 2018 Dernière intervention - 11 juil. 2018 à 11:11
0
Merci
Bonjour,

Merci pour votre rapide retour, et effectivement désolé pour cette imprécision de ma part.

Je me permets de revenir vers vous car désormais je souhaiterai faire l'inverse à savoir que si la valeur contenue en colonne D n'est pas comprise entre - 2 et 2 (soit plus faible que -2, soit plus forte que 2) et si la valeur contenue en colonne E n'est comprise entre -10% et 10% (soit plus faible que -10%, soit plus forte que 10%), alors la valeur de la colonne D devra remontée en colonne F et la valeur de la colonne E devra remontée en colonne G.

Le fichier dispo au lien suivant: https://cjoint.com/c/HGljcK5yU1N

Par avance merci.
Commenter la réponse de pesellier
Vaucluse 22398 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 juillet 2018 Dernière intervention - 11 juil. 2018 à 11:33
0
Merci
re
le plus simple est d'utiliser exactement la même formule en inversant les résultats!
soit donc en F2:
=SI(ET(D2>-2;D2<2;E2>-10%;E2<10%);"";D2)
crdlmnt

pesellier 6 Messages postés mardi 15 novembre 2016Date d'inscription 11 juillet 2018 Dernière intervention - 11 juil. 2018 à 11:59
Super merci beaucoup
Vaucluse 22398 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 juillet 2018 Dernière intervention - 11 juil. 2018 à 12:15
Pas de quoi
si cela résout votre sujet, merci de' le passer en résolu (menu roue dentée en haut à droite du titre du fil)
bonne route
crdlmnt
Commenter la réponse de Vaucluse