Menu

Fonction SI pour la calcule des heures [Résolu]

GaRdOiS - 8 juil. 2018 à 11:53 - Dernière réponse : Patrice33740 7276 Messages postés dimanche 13 juin 2010Date d'inscription 14 septembre 2018 Dernière intervention
- 8 juil. 2018 à 15:15
Bonjour,

j'ai un peut de mal a écrire la formule avec la fonction SI. je m’explique.
j'ai un tableau pour le calcule des heures qui est dispose comme ceci:
colonne A numéro de la semaine
colonne B jour de la semaine
Colonne C heures effectuer
colonne D avec les résulta du calcule

dans la cellule D2 il y a le résultat des heures de la semaine =SOMME(C2:C8) pas problème

dans la cellule D4 le nombre d'heures effectuer entre 35h et 43h =SI(ET(D2>35;D2<43);D2-35;(D2<35=0))

et dans la cellule D6 le nombre heures supérieur a 43 =SI(D2>43;D2-43;0) pas de problème

ma formule en D4 est bien quand D2 et inférieur a 35 = 0 quand D2 est compris entre 35 et 43 = D2-35
j'ai du mal a écrire la formule avec en plus D2 supérieur a 43=8
=SI(ET(D2>35;D2<43);D2-35;(D2<35=0);D2>43=8)

merci pour votre aide
Afficher la suite 

Votre réponse

8 réponses

0
Merci
=SI(OU(ET(D2>35;D2<43);D2-35;(D2<35=0);D2>43=8)) ne fonctionne pas

=SI(OU(ET(D2>35;D2<43);D2-35;(D2<35=0);(D2>43=8))) non plus
Commenter la réponse de GaRdOiS
Patrice33740 7276 Messages postés dimanche 13 juin 2010Date d'inscription 14 septembre 2018 Dernière intervention - 8 juil. 2018 à 12:32
0
Merci
Bonjour,

Avec des heures au format heure (i.e. hh:mm) :
https://mon-partage.fr/f/w5ufjQWV/
bonjour
non au format décimal ex 8.5 pour 8h30min. j'ai du mal a écrire la formule.
Patrice33740 7276 Messages postés dimanche 13 juin 2010Date d'inscription 14 septembre 2018 Dernière intervention - 8 juil. 2018 à 14:26
Alors :
En d4 :
=MIN(MAX(D2-35;0);8)
en D6
=MAX(D2-43;0)

https://mon-partage.fr/f/ZkDuK2re/
j'ai du mal a comprendre le MIN/MAX. la formule de PapyLuc51 fonction exactement comme il me faut
merci a vous pour votre aide.
Patrice33740 7276 Messages postés dimanche 13 juin 2010Date d'inscription 14 septembre 2018 Dernière intervention - 8 juil. 2018 à 15:15
C'est pourtant simple, par besoin de si(), c'est la différence limitée au minimum à 0 et au maximum à 8 heures
Commenter la réponse de Patrice33740
PapyLuc51 1656 Messages postés dimanche 3 mai 2009Date d'inscription 22 septembre 2018 Dernière intervention - 8 juil. 2018 à 14:13
0
Merci
Bonjour,

Ou pour D4

=Si(D2<=35;"";Si(D2>43;8;D2-35))

Cordialement
merci a vous cela fonctionne a merveille est la formule est beaucoup plus simple
Commenter la réponse de PapyLuc51