Menu

RECHERCHE V AVEC SOMME DE LA RECHERCHE [Résolu]

Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 6 juil. 2018 à 13:21 - Dernière réponse :
Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 9 juil. 2018 à 09:24
Bonjour,

N° CPTE Libéllé Montant
101100 CAPITAL SOCIAL -10 000 000 000
121100 RESERVE LEGALE -2 000 000 000
123120 RESERVES SPECIALE -10 000 000 000
123130 RESERVES RISQUES -9 400 000 000
131100 BENEFICES NON AFF -22 187 053 122
183100 COMPTES BLOQUES A -15 000 000 000
188100 DEPOTS ET CAUTION -40 000
189100 DETTES RATTACHEES -175 000 000
191100 PROV.A CARACTER G -11 444 937 213
193110 PROVISION POUR LI -4 861 300 280
193710 PROV.RELATIVES AU -1 656 903 535
201310 FRAIS D'ACQUISITI 226 465 105
201410 FRAIS EXCEPT. A E 126 684 650
202210 FONDS DE COMMERCE 845 298 710
202312 DROIT DE LICENCE 1 327 358 125
791110 REPR.DE PROV.A CA -2 153 603 353
791120 REP.AUTR PROV PR -571 001 076
791130 REPR PROV PR RISQ -94 598 074
791310 REPR.DE PROV.P/DE -1 121 098 915

J'ai un tableau de ce type de pres de 1000 ligne, j'aimerais une formule qui me permette de rechercher par exemple les valeurs des N° CPTE allant de 7911 à 7913 et d'en faire la somme, tout en me permettant d'exclure par exemple 791130.
Afficher la suite 

Votre réponse

12 réponses

Messages postés
9896
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 13:58
0
Merci
Bonjour nbcanh

=SOMME.SI.ENS(C:C;A:A;">=791100";A:A;"<=791399";A:A;"<>791130")

Cdlmnt
Via
Messages postés
48
Date d'inscription
mercredi 1 novembre 2017
Dernière intervention
30 octobre 2018
- 6 juil. 2018 à 15:30
Via55 c,est le best
Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 6 juil. 2018 à 15:33
=SOMME.SI.ENS(C:C;A:A;">=791100";A:A;"<=791399";A:A;"<>791130")
merci encore à vous via55 la formule marche parfaitement. Cependant je veux exclure encore des valeurs comprise donc plus d'une valeur j'ai tenté =SOMME.SI.ENS(C:C;A:A;">=791100";A:A;"<=791399";A:A;"<>791130;791120") mais le résultat n'est pas bon.
En clair j'aimerais exclure plus d'une valeur pour meme exemple : 791130 et 791120
Messages postés
9896
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 19:17
Tu y étais presque !
=SOMME.SI.ENS(C:C;A:A;">=791100";A:A;"<=791399";A:A;"<>791130; A:A;"<> 791120")
Messages postés
22995
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 20:08
salut Via, toi aussi :-))
manque juste un guillemet derrière le 791130
=SOMME.SI.ENS(C:C;A:A;">=791100";A:A;"<=791399";A:A;"<>791130"; A:A;"<> 791120")
pour nbcanh
pour mon info, que donne cette proposition, par rapport à ce que vous demandez?

https://www.commentcamarche.net/forum/affich-35454278-recherche-v-avec-somme-de-la-recherche#10

crdlmnt
Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 9 juil. 2018 à 09:24
Merci à vous les gars via55 et vauclause, je teste les formules à l'instant et ca marche super....Merci encore les gars
Commenter la réponse de via55
Messages postés
22995
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 14:03
0
Merci
Bonour
et quels seraient les arguments pour éliminer certaines références comprises entre les limites des calculs?

à part ça pour sommer les codes dont les 4 premiers chiffres sont >=7911 et <=7913
en commençant en A1 pour aller en A19
et s'il n'y a aucune ligne vide dans le champ des références
(vous pouvez placer un 0 si des cellules sont vides en A pour que la formule fonctionne_voir avec: un 0 dans une cellule / copier / sélectionner le champ A et collage spécial "ajouter")

=SOMMEPROD((GAUCHE(A1:A19;4)*1>=7911)*(GAUCHE(A1:A19;4)*1<=7913)*(C1:C19))

à vous lire pour la suite
crdlmnt
Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 6 juil. 2018 à 14:43
Merci vaucluse,
ca marche mais ca n'exclu pas de la somme le montant de 791130
Messages postés
22995
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 14:59
vi... le but de ma question était de savoir comment identifier ce qu'il ne fallait pas compter, du fait que vous aviez signalé "791130 par exemple ....". S'il y en a qu'un, effectivement Via a fourni la bonne solution.
Bonne toute
crdlmnt
Messages postés
6
Date d'inscription
vendredi 6 juillet 2018
Dernière intervention
9 juillet 2018
- 6 juil. 2018 à 15:22
oui Via a fourni la bonne solution mais votre approche aussi m’intéresse , il n'ya pas de critère spécifique pour exclure un N° COMPTE cela dépend du poste au bilan pour lequel je fais la somme. Donc pour moi ce qui compte c'est de savoir comment exclure une ou plusieurs valeurs.
J’espère avoir répondu à la question, et si votre solution le fait je suis tout aussi preneur.
Messages postés
22995
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 6 juil. 2018 à 16:00
c'est à quelque chose comme ça que je pensais, pour éliminer une liste d'un cumul entre limites
https://mon-partage.fr/f/x81kPS29/
(qui suppose que les valeurs des références sont numériques)
Commenter la réponse de Vaucluse