Recherchev sur feuille non fixe [Résolu/Fermé]

Messages postés
2
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
18 juin 2018
- - Dernière réponse : jc80
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
- 18 juin 2018 à 13:27
Bonjour,

J'essaie actuellement d'utiliser la fonction RECHERCHEV sur une feuille dont le nom est mis à jour chaque semaine.Pour le moment j'utilise la formule suivante : =RECHERCHEV(A2;'Data s23'!A:BF;58;0).
La feuille est générée automatiquement par une macro chaque semaine. Je souhaite que la mise à jour du nom de la feuille dans ma fonction soit automatique. Cela est-il possible et si oui comment faire ?

Merci.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1053
1
Merci
Bonjour
Ci-dessous la solution àa adapter à ton fichier

https://www.commentcamarche.net/forum/affich-17372566-recherchev-avec-feuille-variable
Cordialement

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62632 internautes nous ont dit merci ce mois-ci

Messages postés
658
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
28 septembre 2019
45
0
Merci
Bonjour,

Le plus simple serait que la macro génère ta formule ou mette le numéro de semaine dans une cellule. Sinon,, est-ce que tu peux calculer ou est-ce que tu connais le numéro de semaine ?

Cordialement.

Daniel
Messages postés
2
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
18 juin 2018
0
Merci
Merci jc80, problème résolu ;)

à bientot
jc80
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1053 -
Bonne journée à toi
Crdlt