Formule faisant référence à une cellule fixe [Fermé]

- - Dernière réponse : jc80
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
- 13 juin 2018 à 15:10
Bonjour,

Dans un tableau, j'ai une ligne de 50 cellules contenant des nombres. Une macro supprime la dernière cellule de la ligne, fait un copier/coller des 49 cellules restantes pour les décaler vers la droite d'une cellule et introduit une valeur dans la première cellule. Jusque là tout va bien.

Dans une autre cellule, une formule calcule la somme de ces 50 cellules soit : =SOMME(B6:AY6).

Lorsque j'effectue ma macro, ma formule est décalée vers la droit et devient = =SOMME(C6:AZ6)

Je pensais qu'en modifiant ma formule comme ceci : =SOMME($B$6:$AY$6), ça solutionnerait le problème mais pas du tout.

J'ai également donné un nom à la plage $B$6:$AZ$6 mais ladite plage nommée est également décalée lors de l'activation de la macro.

Juste pour être complet, calculer la somme sur toute la ligne n'est pas une solution car j'ai simplifié le problème mais je voudrais calculer plusieurs plages (5, 10, 20) sur cette ligne.

Auriez-vous une idée pour solutionner ce problème ?

Merci d'avance.

François


Afficher la suite 

2 réponses

Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1062
0
Merci
Bonjour

U exemple de ton fichier serait le bienvenu
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..

Cordialement
https://www.cjoint.com/c/HFnmub8iZlZ
Le premier lien semblait ne pas fonctionner, j'essaie encore : https://www.cjoint.com/c/HFnmCaASDJZ
Le fichier fonctionne chez moi mais ne fonctionne pas lorsque je le télécharge via Cjoint…
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1062
0
Merci
Bonjour

La VBA n’étant pas mon fort j'ai fait transférer ta demande dans le bon forum VBA
Cordialement